Bug 214687 - security/gpgme-qt5 : fix build on 9.3-i386
Summary: security/gpgme-qt5 : fix build on 9.3-i386
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jason E. Hale
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-20 12:09 UTC by Tobias C. Berner
Modified: 2016-11-21 12:29 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (jhale)


Attachments
Fix build on 9.3@32 (1.20 KB, patch)
2016-11-20 12:09 UTC, Tobias C. Berner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias C. Berner freebsd_committer 2016-11-20 12:09:58 UTC
Created attachment 177205 [details]
Fix build on 9.3@32

Hi

security/gpgme-qt5 fails to build for me on 9.3@32.
>   error: 'sscanf' is not a member of 'std'


The attached patch includes <cstdio> in lang/cpp/src/engineinfo.h.



mfg Tobias
Comment 1 Jason E. Hale freebsd_committer 2016-11-21 12:07:53 UTC
(In reply to Tobias C. Berner from comment #0)

Hmm...it builds for me and rakuco assured me it built after his changes. I'm not sure why if it errored out for gpgme-qt5 that it didn't error for gpgme-cpp since engineinfo.h is part of that too.  I'll add it though, since it seems like it should be there.
Comment 2 Tobias C. Berner freebsd_committer 2016-11-21 12:10:08 UTC
I think the gcc4.8->gcc4.9update broke this. Which happend during the import of the patch by rakuco :)
Comment 3 Jason E. Hale freebsd_committer 2016-11-21 12:15:29 UTC
(In reply to Tobias C. Berner from comment #2)
Ah, that would explain it. I'll get this in. Thanks!
Comment 4 commit-hook freebsd_committer 2016-11-21 12:27:35 UTC
A commit references this bug:

Author: jhale
Date: Mon Nov 21 12:27:16 UTC 2016
New revision: 426708
URL: https://svnweb.freebsd.org/changeset/ports/426708

Log:
  Fix build of security/gpgme-qt5 with gcc49

  In file included from qgpgmebackend.cpp:42:0:
  ../../../lang/cpp/src/engineinfo.h: In constructor
    'GpgME::EngineInfo::Version::Version(const string&)':
  ../../../lang/cpp/src/engineinfo.h:47:17: error: 'sscanf' is not a
    member of 'std'
        std::sscanf(version.c_str(), "%d.%d.%d", &major, &minor, &patch) != 3) {

  PR:		214687
  Submitted by:	tcberner

Changes:
  head/security/gpgme/files/patch-lang_cpp_src_engineinfo.h