Bug 214752 - databases/pgrouting: Update to 2.3.1
Summary: databases/pgrouting: Update to 2.3.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jason Unovitch
URL:
Keywords: easy, patch-ready
Depends on:
Blocks:
 
Reported: 2016-11-22 18:49 UTC by Loïc Bartoletti
Modified: 2016-12-14 02:48 UTC (History)
1 user (show)

See Also:
lbartoletti: maintainer-feedback+


Attachments
Update pgrouting to 2.3.1 (3.31 KB, patch)
2016-11-22 18:49 UTC, Loïc Bartoletti
lbartoletti: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Loïc Bartoletti 2016-11-22 18:49:40 UTC
Created attachment 177292 [details]
Update pgrouting to 2.3.1

portlint ok
poudriere 9, 10, 11 i386/amd64 OK


Changes for 2.3.1

    Bug fixes
        Leaks on proposed max_flow functions
        Regression error on pgr_trsp
        Types discrepancy on pgr_createVerticesTable

    Read the documentation of this release at http://docs.pgrouting.org/2.3/en/doc/index.html
    To see the full list of changes check the list of Git commits on Github.
    To see the issues closed by this release see the Git closed issues on Github.
Comment 1 commit-hook freebsd_committer 2016-12-14 02:39:05 UTC
A commit references this bug:

Author: junovitch
Date: Wed Dec 14 02:38:04 UTC 2016
New revision: 428540
URL: https://svnweb.freebsd.org/changeset/ports/428540

Log:
  databases/pgrouting: update 2.3.0 -> 2.3.1

  PR:		214752
  Submitted by:	lbartoletti@tuxfamily.org (maintainer)

Changes:
  head/databases/pgrouting/Makefile
  head/databases/pgrouting/distinfo
  head/databases/pgrouting/files/patch-src_trsp_src_GraphDefinition.cpp
  head/databases/pgrouting/pkg-plist
Comment 2 Jason Unovitch freebsd_committer 2016-12-14 02:48:41 UTC
Sorry for delay, I got mildly sidetracked on the initial QA double check for 12.0 coverage when it didn't build. This was due to postgis not building because I use pgsql=9.6 in my DEFAULT_VERSIONS. After postgis being fixed for compat with 9.6 I successfully tested with both default PostgreSQL 9.3 and PostgreSQL 9.6 set in DEFAULT_VERSIONS.