Bug 214780 - Ports should not use post-stage, its usage case was never defined
Summary: Ports should not use post-stage, its usage case was never defined
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mathieu Arnold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-23 12:06 UTC by Mathieu Arnold
Modified: 2016-12-02 11:58 UTC (History)
2 users (show)

See Also:
mat: exp-run?


Attachments
v1 (64.02 KB, patch)
2016-11-23 12:06 UTC, Mathieu Arnold
no flags Details | Diff
v2 (58.32 KB, patch)
2016-11-28 16:12 UTC, Mathieu Arnold
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Arnold freebsd_committer 2016-11-23 12:06:47 UTC
Created attachment 177328 [details]
v1
Comment 1 Antoine Brodin freebsd_committer 2016-11-27 08:14:10 UTC
There is this new warning with the patch applied:

make: "/usr/ports/databases/mariadb101-client/../mariadb101-server/Makefile" line 110: warning: duplicate script for target "post-install" ignored
make: "/usr/ports/databases/mariadb101-client/../mariadb101-server/Makefile" line 34: warning: using previous script for "post-install" defined here
Comment 3 Antoine Brodin freebsd_committer 2016-11-27 19:18:33 UTC
Complete list of new failures:


http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/mariadb101-client-10.1.19_1.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/gcc-4.9.4.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/gcc46-4.6.4_5,1.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/gcc47-4.7.4_3,1.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/gcc48-4.8.5_1.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/gcc49-4.9.4.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/gcc5-5.4.0.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/gcc5-aux-20160603.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/gcc5-devel-5.4.1.s20161122.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/gcc6-6.2.0.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/gcc6-aux-20160822.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/gcc6-devel-6.2.1.s20161117.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/gcc7-devel-7.0.0.s20161120.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-27_08h09m31s/logs/transcode-1.1.7_27.log

All the ports depending on gcc* were skipped.
Comment 4 Mathieu Arnold freebsd_committer 2016-11-28 16:12:55 UTC
Created attachment 177487 [details]
v2

remove patches for gcc* and transcode, fix mariadb.
Comment 5 Antoine Brodin freebsd_committer 2016-11-30 06:22:33 UTC
With v2 there are 2 new failures on 10.3 i386:

+ {"origin"=>"lang/gnatdroid-armv7", "phase"=>"package", "errortype"=>"???"}
+ {"origin"=>"lang/gnatdroid-x86", "phase"=>"package", "errortype"=>"???"}

Failure logs:

http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-29_23h00m56s/logs/errors/gnatdroid-armv7-20160822.log
http://package22.nyi.freebsd.org/data/103i386-default-PR214780/2016-11-29_23h00m56s/logs/errors/gnatdroid-x86-20160822.log
Comment 6 Mathieu Arnold freebsd_committer 2016-11-30 14:32:11 UTC
Ok, remove the patch for lang/gnatdroid-armv7. (the -x86 is a slave)

Let me know if some other regression come out.
Comment 7 Antoine Brodin freebsd_committer 2016-12-01 23:46:03 UTC
Exp-run looks fine.
Comment 8 commit-hook freebsd_committer 2016-12-02 11:58:58 UTC
A commit references this bug:

Author: mat
Date: Fri Dec  2 11:58:31 UTC 2016
New revision: 427552
URL: https://svnweb.freebsd.org/changeset/ports/427552

Log:
  Do not use post-stage.  Use post-install instead.

  The only reason to use post-stage is because the port needs to do
  "things" at a later time, like some plist manipulation.
  While there, fold post-install in do-install targets when they are
  defined.

  PR:		214780
  Submitted by:	mat
  Exp-run by:	antoine
  Sponsored by:	Absolight

Changes:
  head/archivers/p5-Compress-LZ4/Makefile
  head/astro/p5-Starlink-AST/Makefile
  head/audio/libogg/Makefile
  head/audio/libvorbis/Makefile
  head/audio/p5-Net-FreeDB/Makefile
  head/biology/cd-hit/Makefile
  head/cad/tkgate/Makefile
  head/comms/qsstv/Makefile
  head/comms/svxlink/Makefile
  head/comms/trustedqsl/Makefile
  head/databases/cego/Makefile
  head/databases/mariadb100-client/Makefile
  head/databases/mariadb101-client/Makefile
  head/databases/mariadb101-server/Makefile
  head/databases/mysql57-server/Makefile
  head/databases/p5-DBD-Pg/Makefile
  head/databases/p5-DBD-cego/Makefile
  head/databases/p5-DBD-mysql/Makefile
  head/databases/py-carbon/Makefile
  head/databases/sqlrelay/Makefile
  head/devel/R-cran-plyr/Makefile
  head/devel/arm-none-eabi-gcc492/Makefile
  head/devel/avr-gcc/Makefile
  head/devel/avr-gcc-devel/Makefile
  head/devel/efl/Makefile
  head/devel/gcc-msp430-ti-toolchain/Makefile
  head/devel/google-gdata/Makefile
  head/devel/google-perftools/Makefile
  head/devel/icu/Makefile
  head/devel/ivykis/Makefile
  head/devel/lfcbase/Makefile
  head/devel/libmpsse/Makefile
  head/devel/liborcus07/Makefile
  head/devel/libtermkey/Makefile
  head/devel/mongo-c-driver/Makefile
  head/devel/msgpack/Makefile
  head/devel/ocaml-camlp4/Makefile
  head/devel/ocaml-ppx-tools/Makefile
  head/devel/opendht/Makefile
  head/devel/p5-CBOR-XS/Makefile
  head/devel/p5-Data-Peek/Makefile
  head/devel/pcre/Makefile
  head/devel/py-llfuse/Makefile
  head/devel/rapidjson/Makefile
  head/devel/rubygem-rice/Makefile
  head/devel/spatialindex/Makefile
  head/dns/adns/Makefile
  head/dns/powerdns/Makefile
  head/emulators/pipelight/Makefile
  head/finance/bitcoin-armory/Makefile
  head/graphics/libart_lgpl/Makefile
  head/graphics/linux-c6-dri/Makefile
  head/graphics/linux-c7-dri/Makefile
  head/graphics/pfstools/Makefile
  head/graphics/py-graph-dot/Makefile
  head/irc/bopm/Makefile
  head/japanese/ebnetd/Makefile
  head/lang/dmd2/Makefile.bootstrap
  head/lang/p5-List-MoreUtils/Makefile
  head/lang/py-mx-base/Makefile
  head/lang/smlnj/Makefile
  head/mail/dcc-dccd/Makefile
  head/mail/fetchmail/Makefile
  head/mail/libsrs2/Makefile
  head/mail/libsrs_alt/Makefile
  head/mail/msmtp/Makefile
  head/mail/postfix/Makefile
  head/mail/postfix-current/Makefile
  head/mail/postfix211/Makefile
  head/mail/rmilter/Makefile
  head/mail/rspamd/Makefile
  head/math/p5-Math-Int128/Makefile
  head/multimedia/libav/Makefile
  head/multimedia/mpv/Makefile
  head/net/bctoolbox/Makefile
  head/net/chrony/Makefile
  head/net/h323plus/Makefile
  head/net/kamailio/Makefile
  head/net/libp0f/Makefile
  head/net/linphone/Makefile
  head/net/mosquitto/Makefile
  head/net/openggsn/Makefile
  head/net/openntpd/Makefile
  head/net/opensips/Makefile
  head/net/whois/Makefile
  head/net/yate/Makefile
  head/net-im/libpurple/Makefile
  head/net-im/pidgin/Makefile
  head/net-im/ring-daemon/Makefile
  head/net-im/ring-gnome/Makefile
  head/net-mgmt/netmagis-topo/Makefile
  head/net-mgmt/prometheus/Makefile
  head/net-p2p/btsync/Makefile
  head/science/gnudatalanguage/Makefile
  head/science/mcstas/Makefile
  head/security/fwknop/Makefile
  head/security/libressl/Makefile
  head/security/libressl-devel/Makefile
  head/security/openca-tools-forked/Makefile
  head/security/p5-Crypt-GCrypt/Makefile
  head/security/p5-Crypt-OpenSSL-X509/Makefile
  head/security/p5-Crypt-SMIME/Makefile
  head/security/p5-Digest-GOST/Makefile
  head/security/p5-openxpki/Makefile
  head/sysutils/amtc/Makefile
  head/sysutils/clone/Makefile
  head/sysutils/osquery/Makefile
  head/textproc/expat2/Makefile
  head/textproc/libwps03/Makefile
  head/textproc/libxslt/Makefile
  head/textproc/p5-Net-IDN-Encode/Makefile
  head/www/gitea/Makefile
  head/www/libapreq2/Makefile
  head/www/madsonic/Makefile
  head/www/p5-libapreq2/Makefile
  head/www/py-goobook/Makefile
  head/www/subsonic/Makefile
  head/www/wt/Makefile
  head/x11-toolkits/p5-Tk/Makefile