Bug 214793 - devel/boost-libs: fix incompatibility with LibreSSL
Summary: devel/boost-libs: fix incompatibility with LibreSSL
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-office mailing list
URL:
Keywords: patch, regression
Depends on:
Blocks: 199601
  Show dependency treegraph
 
Reported: 2016-11-23 20:11 UTC by Matthew Rezny
Modified: 2016-11-24 02:35 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments
fix compilation of software using libressl and boost asio (2.96 KB, patch)
2016-11-23 20:11 UTC, Matthew Rezny
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Rezny freebsd_committer 2016-11-23 20:11:20 UTC
Created attachment 177343 [details]
fix compilation of software using libressl and boost asio

The recent update of Boost to 1.62 introduced an incompatibility with LibreSSl due to inadequate version checks around OpenSSL 1.1 functions. The attached patch comes from Boost's Trac and resolves the build failure in libtorrent-rasterbar that occurred after the Boost update.
Comment 1 commit-hook freebsd_committer 2016-11-24 02:31:17 UTC
A commit references this bug:

Author: jbeich
Date: Thu Nov 24 02:30:37 UTC 2016
New revision: 426988
URL: https://svnweb.freebsd.org/changeset/ports/426988

Log:
  devel/boost-libs: unbreak consumers with libressl

  $ make WITH=ASIO -C www/nghttp2
  [...]
  In file included from asio_common.cc:25:
  In file included from ./asio_common.h:32:
  In file included from ../src/includes/nghttp2/asio_http2.h:37:
  In file included from /usr/local/include/boost/asio/ssl.hpp:19:
  In file included from /usr/local/include/boost/asio/ssl/context.hpp:786:
  /usr/local/include/boost/asio/ssl/impl/context.ipp:232:27: error: no member named 'SSL_CTX_get_default_passwd_cb_userdata' in the global namespace; did you mean 'SSL_CTX_set_default_passwd_cb_userdata'?
      void* cb_userdata = ::SSL_CTX_get_default_passwd_cb_userdata(handle_);
                          ~~^
  /usr/local/include/openssl/ssl.h:1640:6: note: 'SSL_CTX_set_default_passwd_cb_userdata' declared here
  void SSL_CTX_set_default_passwd_cb_userdata(SSL_CTX *ctx, void *u);
       ^

  PR:		214793
  Submitted by:	matthew@reztek.cz
  Obtained from:	upstream (via Gentoo)
  Approved by:	portmgr blanket

Changes:
  head/devel/boost-libs/Makefile
  head/devel/boost-libs/files/patch-boost_asio_ssl_impl_context.ipp