Bug 214797 - devel/boost-python-libs: make check-plist fails with python3
Summary: devel/boost-python-libs: make check-plist fails with python3
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2016-11-24 04:49 UTC by Jan Beich
Modified: 2018-09-09 17:29 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2016-11-24 04:49:22 UTC
$ echo DEFAULT_VERSIONS += python=3.5 >>/usr/local/etc/poudriere.d/make.conf
$ poudriere testport -j 101i386 -o devel/boost-python-libs
[...]
===========================================================================
====> Running Q/A tests (stage-qa)
Warning: 'lib/libboost_python3.so.1.62.0' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: lib/libboost_python3.a
Error: Orphaned: lib/libboost_python3.so
Error: Orphaned: lib/libboost_python3.so.%%BOOST_SHARED_LIB_VER%%
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1

Note, the issue was present before bug 199601 landed.
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-01-14 05:19:03 UTC
Maintainer feedback?
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-02-12 21:59:29 UTC
Problem still exists with boost-python-libs-1.66.0:
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: lib/libboost_numpy.a
Error: Orphaned: lib/libboost_numpy.so
Error: Orphaned: lib/libboost_numpy.so.%%BOOST_SHARED_LIB_VER%%
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1
Comment 3 Walter Schwarzenfeld freebsd_triage 2018-02-12 22:04:21 UTC
I was not exact: Problem exists on 10.4, but not on 11.1.
Comment 4 Jan Beich freebsd_committer 2018-09-09 17:29:27 UTC
comment 0 was probably fixed by ports r442853. comment 2 is a duplicate of bug 225589.