Bug 214810 - net/asterisk11: Providing a custom .asterisk.makeopts file doesn't work anymore
Summary: net/asterisk11: Providing a custom .asterisk.makeopts file doesn't work anymore
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Guido Falsi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-24 16:20 UTC by Yani Karydis
Modified: 2016-12-11 15:36 UTC (History)
0 users

See Also:
madpilot: maintainer-feedback+


Attachments
Makefile patch to copy the custom .asterisk.makeopts file to the work directory (643 bytes, patch)
2016-11-24 16:20 UTC, Yani Karydis
no flags Details | Diff
asterisk11.diff (930 bytes, patch)
2016-11-24 22:22 UTC, Guido Falsi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yani Karydis 2016-11-24 16:20:34 UTC
Created attachment 177361 [details]
Makefile patch to copy the custom .asterisk.makeopts file to the work directory

Using a custom ".asterisk.makeopts" file doesn't work anymore, the "USER_MAKEOPTS_FILE" variable setup in the ports Makefile and passed to "make menuselect.makeopts" doesn't seem to have any effect.

A workaround (as per the upstream Makefile's comments) is to use a straight copy of the custom ".asterisk.makeopts" file to "menuselect.makeopts" in the working directory before running "make menuselect.makeopts". I'm attaching a patch to the ports Makefile which fixes the problem.
Comment 1 Guido Falsi freebsd_committer 2016-11-24 18:40:32 UTC
Thanks for letting me know.

I'll test your patch.

I will need a little time because at present I'm fighting with the latest asterisk update, and I will merge your change with that, once it's ready.
Comment 2 Guido Falsi freebsd_committer 2016-11-24 22:22:49 UTC
Created attachment 177363 [details]
asterisk11.diff

I reimplemented your fix in a slightly different way for inclusion.

Can you please test this new patch and report back if it works as expected?

Thanks in advance.
Comment 3 Yani Karydis 2016-11-24 23:29:24 UTC
Hello,

Thanks for sending the new patch. I gave it a try and it works fine.

Regards
Comment 4 commit-hook freebsd_committer 2016-11-25 10:47:24 UTC
A commit references this bug:

Author: madpilot
Date: Fri Nov 25 10:46:41 UTC 2016
New revision: 427102
URL: https://svnweb.freebsd.org/changeset/ports/427102

Log:
  - Update asterisk11 to 11.25.0
  - Make user provided makeopts work again [1]

  PR:		214810 [1]
  Submitted by:	yani@pi-greece.eu

Changes:
  head/net/asterisk11/Makefile
  head/net/asterisk11/distinfo
Comment 5 commit-hook freebsd_committer 2016-11-25 10:47:26 UTC
A commit references this bug:

Author: madpilot
Date: Fri Nov 25 10:47:21 UTC 2016
New revision: 427103
URL: https://svnweb.freebsd.org/changeset/ports/427103

Log:
  - Update asterisk13 to 13.13.0
  - Make user provided makeopts work again [1]

  PR:		214810 [1]
  Submitted by:	yani@pi-greece.eu

Changes:
  head/net/asterisk13/Makefile
  head/net/asterisk13/distinfo
  head/net/asterisk13/files/patch-main_udptl.c
  head/net/asterisk13/files/patch-res_res__rtp__asterisk.c
Comment 6 Guido Falsi freebsd_committer 2016-11-25 10:48:48 UTC
Committed together with the update to the latest version.

Thanks!
Comment 7 commit-hook freebsd_committer 2016-12-11 15:31:09 UTC
A commit references this bug:

Author: madpilot
Date: Sun Dec 11 15:30:15 UTC 2016
New revision: 428355
URL: https://svnweb.freebsd.org/changeset/ports/428355

Log:
  MFH: r424696 r424814 r427102 r428327

  - Update asterisk11 to 11.25.1 [2]
  - Make user provided makeopts work again [1]

  PR:		214810 [1]
  Submitted by:	yani@pi-greece.eu
  Security:	c0b13887-be44-11e6-b04f-001999f8d30b [2]

  Approved by:	ports-secteam (junovitch)

Changes:
_U  branches/2016Q4/
  branches/2016Q4/net/asterisk11/Makefile
  branches/2016Q4/net/asterisk11/distinfo
Comment 8 commit-hook freebsd_committer 2016-12-11 15:36:15 UTC
A commit references this bug:

Author: madpilot
Date: Sun Dec 11 15:35:35 UTC 2016
New revision: 428356
URL: https://svnweb.freebsd.org/changeset/ports/428356

Log:
  MFH: r424697 r424815 r425883 r427103 r427462 r428328

  - Update asterisk13 to 13.13.1 [3]
  - Include patches submitted upstream to fix a regression [2]
  - Make user provided makeopts work again [1]

  PR:		214810 [1]
  Submitted by:	yani@pi-greece.eu
  Obtained from:  https://issues.asterisk.org/jira/browse/ASTERISK-26617 [2]
  Security:	c0b13887-be44-11e6-b04f-001999f8d30b [3]
  Security:	9e6640fe-be3a-11e6-b04f-001999f8d30b [3]

  Approved by:	ports-secteam (junovitch)

Changes:
_U  branches/2016Q4/
  branches/2016Q4/net/asterisk13/Makefile
  branches/2016Q4/net/asterisk13/distinfo
  branches/2016Q4/net/asterisk13/files/patch-include_asterisk_utils.h
  branches/2016Q4/net/asterisk13/files/patch-main_utils.c
  branches/2016Q4/net/asterisk13/files/patch-res_res__pjsip__sdp__rtp.c
  branches/2016Q4/net/asterisk13/files/patch-res_res__pjsip__t38.c
  branches/2016Q4/net/asterisk13/files/patch-res_res__rtp__asterisk.c