Bug 214853 - math/py-matplotlib: Enable building with python 3
Summary: math/py-matplotlib: Enable building with python 3
Status: Closed DUPLICATE of bug 213636
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: FreeBSD Ports Bugs (Mailing List)
URL:
Keywords: needs-qa, patch
Depends on:
Blocks:
 
Reported: 2016-11-26 15:03 UTC by rsmith
Modified: 2017-01-02 19:01 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (mainland)
vlad-fbsd: merge-quarterly?


Attachments
Patch for the math/py-matplotlib port Makefile. (578 bytes, patch)
2016-11-26 15:03 UTC, rsmith
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rsmith 2016-11-26 15:03:08 UTC
Created attachment 177417 [details]
Patch for the math/py-matplotlib port Makefile.

The recent revision 426883 restricted matplotlib to Python 2.7 because it fails with Python 3.

However, this is *only true* in the default configuration.
When the gtk and gtkagg backends are disabled and the tkagg backend is enabled, matplotlib builds, installs and works fine with Python 3 (tested with Python 3.5) if I change `python:2.7` back to `python` in USES.

The attached patch adds the correct python to USES after the options are processed. But the build fails for some reason that I do not understand. During `make PYTHON_VERSION=python3.5 build` it says that matplotlib depends on `tkinter>0`, which it says it cannot find even though py35-tkinter-3.5.2_6 is already installed.

Probably this needs to done differently, but I don't see how.
Comment 1 c.brinkhaus 2016-12-31 18:29:50 UTC
The report seems to be a duplicate to https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=213636.
Comment 2 rsmith 2017-01-02 19:01:28 UTC
This is basically the same as https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=213636. 

This can be closed in favor of 213636.

*** This bug has been marked as a duplicate of bug 213636 ***