Bug 214942 - devel/boost-libs: mark BROKEN on various tier-2 archs
Summary: devel/boost-libs: mark BROKEN on various tier-2 archs
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-30 02:59 UTC by Mark Linimon
Modified: 2017-06-14 08:24 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments
patch to devel/boost-libs/Makefile (493 bytes, patch)
2016-11-30 02:59 UTC, Mark Linimon
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Linimon freebsd_committer freebsd_triage 2016-11-30 02:59:51 UTC
Created attachment 177529 [details]
patch to devel/boost-libs/Makefile

boost-libs has proven to be broken on sparc64.

This patch also adds back the aarch64 line originally added in r426143 but later removed in r426908.  It is still failing on aarch64.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2016-11-30 03:00:28 UTC
Cc: committer of r426908.
Comment 2 Jan Beich freebsd_committer 2016-11-30 07:45:34 UTC
Comment on attachment 177529 [details]
patch to devel/boost-libs/Makefile

>+BROKEN_aarch64=		Fails to compile: multiple instances of error: platform not supported

According to bug 213867 the error message should be different with Boost 1.62. So, limit to FreeBSD releases with Clang < 3.9 i.e., FreeBSD <= 11.0. Later versions may build fine but so far no one volunteered to confirm.

>+BROKEN_sparc64=		Fails to compile: multiple instances of error: platform not supported

Looks OK considering https://github.com/boostorg/context/commit/f2ef6326b6ed
Comment 3 commit-hook freebsd_committer 2017-01-01 10:51:23 UTC
A commit references this bug:

Author: jbeich
Date: Sun Jan  1 10:50:48 UTC 2017
New revision: 430247
URL: https://svnweb.freebsd.org/changeset/ports/430247

Log:
  devel/boost-libs: unblock aarch64 and sparc64 builds

  - aarch64 requires Clang with new enough integrated assembler
  - sparc64 is no longer supported since we don't split context library
    into a separate package (unlike Debian)

  PR:		213867 214942
  MFH:		2016Q4

Changes:
  head/devel/boost-libs/Makefile
Comment 4 Jan Beich freebsd_committer 2017-06-14 08:24:08 UTC
sparc64 can probably be unbroken based on https://github.com/openbsd/ports/commit/8495a25bd4e1