Bug 214975 - [exp-run] update devel/cmake* to 3.7.1
Summary: [exp-run] update devel/cmake* to 3.7.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-01 09:02 UTC by Tobias C. Berner
Modified: 2016-12-09 11:42 UTC (History)
3 users (show)

See Also:


Attachments
Update devel/cmake* to 3.7.1 (57.76 KB, patch)
2016-12-01 09:02 UTC, Tobias C. Berner
no flags Details | Diff
update cmake to 3.7.1 and override CMAKE_INSTALL_MANDIR in the mentioned llvm ports (60.03 KB, patch)
2016-12-04 21:04 UTC, Tobias C. Berner
no flags Details | Diff
fix fallouts (66.43 KB, patch)
2016-12-05 11:02 UTC, Tobias C. Berner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias C. Berner freebsd_committer 2016-12-01 09:02:11 UTC
Created attachment 177568 [details]
Update devel/cmake* to 3.7.1

Hi 

kde@ would like to as for an exp-run to update devel/cmake & friends to 3.7.1. 

The diff is attached and can also be found here:
http://people.freebsd.org/~tcberner/patches/cmake-3.7.1.diff.v1
Comment 1 Antoine Brodin freebsd_committer 2016-12-04 08:12:36 UTC
New failures on 11.0 amd64:

+ {"origin"=>"devel/llvm-devel", "phase"=>"stage", "errortype"=>"manpage"}
+ {"origin"=>"devel/llvm37", "phase"=>"stage", "errortype"=>"manpage"}
+ {"origin"=>"devel/llvm38", "phase"=>"stage", "errortype"=>"manpage"}
+ {"origin"=>"devel/llvm39", "phase"=>"stage", "errortype"=>"manpage"}

1259 ports were skipped

Failure logs:

http://package22.nyi.freebsd.org/data/110amd64-default-PR214975/2016-12-03_21h13m34s/logs/errors/llvm-devel-4.0.d20161122.log
http://package22.nyi.freebsd.org/data/110amd64-default-PR214975/2016-12-03_21h13m34s/logs/errors/llvm37-3.7.1_4.log
http://package22.nyi.freebsd.org/data/110amd64-default-PR214975/2016-12-03_21h13m34s/logs/errors/llvm38-3.8.1_5.log
http://package22.nyi.freebsd.org/data/110amd64-default-PR214975/2016-12-03_21h13m34s/logs/errors/llvm39-3.9.0_4.log
Comment 2 Tobias C. Berner freebsd_committer 2016-12-04 21:04:03 UTC
Created attachment 177667 [details]
update cmake to 3.7.1 and override CMAKE_INSTALL_MANDIR in the mentioned llvm ports

As rakuco found out, this is caused by the upstream commit 
https://github.com/kitware/cmake/commit/956054aeca0cff2ef5a8c92586e992cc9ad51d7d
which properly sets the man-paths in cmake now. The easiest work-around is to force cmake to use the "wrong" path as before: so set it to 'share/man' via CMAKE_INSTALL_MANDIR.
[The alternative is to touch the man-page shuffle in the llvm*/Makefiles, which is a bigger change, than just setting CMAKE_INSTALL_MANDIR -- and maybe can/should be done at a later time].


The new patch is attached, and can also be found here 
http://people.freebsd.org/~tcberner/patches/cmake-3.7.1.v2
Comment 4 Tobias C. Berner freebsd_committer 2016-12-05 11:02:31 UTC
Created attachment 177684 [details]
fix fallouts

New patch:
http://people.freebsd.org/~tcberner/patches/cmake-3.7.1.v3

* Fix plist of net/remmina
* Add upstream patch for math/plplot [1]

[1] https://sourceforge.net/p/plplot/plplot/ci/db396b9fbdc9cd54fb8545ea655185ca73a2a07e/
Comment 5 Antoine Brodin freebsd_committer 2016-12-09 06:53:06 UTC
Exp-run looks fine
Comment 6 commit-hook freebsd_committer 2016-12-09 11:41:43 UTC
A commit references this bug:

Author: tcberner
Date: Fri Dec  9 11:41:00 UTC 2016
New revision: 428179
URL: https://svnweb.freebsd.org/changeset/ports/428179

Log:
  Update devel/cmake* to 3.7.1 [1]

  Due to an upstream commit [2] we need now to pass
  CMAKE_INSTALL_MANDIR:PATH="share/man" in the
  devel/llvm-* ports, and fix the plist of net/remmina.
  Further add an upstream patch to  math/plplot to
  fix the build with 3.7.1.

  [1] https://cmake.org/cmake/help/v3.7/release/3.7.html
  [2] https://github.com/kitware/cmake/commit/956054

  PR:		214975
  Approved by:	rakuco (mentor)
  Exp-run by:	antoine

Changes:
  head/devel/cmake/Makefile
  head/devel/cmake/distinfo
  head/devel/cmake/files/patch-git_5ec17e61
  head/devel/cmake/pkg-plist
  head/devel/cmake-doc/Makefile
  head/devel/cmake-doc/pkg-plist
  head/devel/cmake-gui/Makefile
  head/devel/cmake-gui/files/patch-git_5ec17e61
  head/devel/cmake-modules/pkg-plist
  head/devel/llvm-devel/Makefile
  head/devel/llvm37/Makefile
  head/devel/llvm38/Makefile
  head/devel/llvm39/Makefile
  head/math/plplot/files/patch-git_db396b
  head/net/remmina/Makefile
  head/net/remmina/pkg-plist
Comment 7 Tobias C. Berner freebsd_committer 2016-12-09 11:42:38 UTC
Committed.

Thanks for the exp-run.