Bug 214993 - gmirror panic with newfs -E
Summary: gmirror panic with newfs -E
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.0-STABLE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-02 08:14 UTC by Poul-Henning Kamp
Modified: 2016-12-06 18:29 UTC (History)
1 user (show)

See Also:


Attachments
console grab with panic (2.64 KB, text/plain)
2016-12-02 08:14 UTC, Poul-Henning Kamp
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Poul-Henning Kamp freebsd_committer 2016-12-02 08:14:18 UTC
Created attachment 177592 [details]
console grab with panic

Two new samsung EVO850 1TB ssds

geom_mirror mirror

newfs -U -O 2 -t -E -b 65536 -f 8192

Bewm in attachment.

It's perfectly fine to detach drives and destroy the mirror, but the panic is not ok given the circumstances.
Comment 1 Mark Johnston freebsd_committer 2016-12-02 17:12:05 UTC
Which revision was this? r302091 should have addressed this bug.
Comment 2 Poul-Henning Kamp freebsd_committer 2016-12-02 17:13:26 UTC
Sorry for not reporting that, the kernel is r298283M on this system.

I will try a newer kernel and report back.
Comment 3 Poul-Henning Kamp freebsd_committer 2016-12-02 18:20:44 UTC
I tried on a different machine, running 11.0-RELEASE-p2, and that didn't reproduce the problem.

It will be some days before I can try a new kernel on the original HW, will report back.
Comment 4 Poul-Henning Kamp freebsd_committer 2016-12-06 18:29:34 UTC
You're right, it seems to be fixed.