Bug 214998 - sysutils/py-salt: Fix OpenSSL 1.1 compatibility
Summary: sysutils/py-salt: Fix OpenSSL 1.1 compatibility
Status: Closed DUPLICATE of bug 215051
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-02 10:25 UTC by Melvyn Sopacua
Modified: 2016-12-05 15:01 UTC (History)
3 users (show)

See Also:


Attachments
Patch to fix openssl 1.1. compatibilty (4.50 KB, patch)
2016-12-02 10:25 UTC, Melvyn Sopacua
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Melvyn Sopacua 2016-12-02 10:25:43 UTC
Created attachment 177598 [details]
Patch to fix openssl 1.1. compatibilty

Salt does not initialize when compiled against OpenSSL 1.1, due to a call to OpenSSL_no_config, which changed from a library symbol to a header define, making it impossible for CPython to call the function.

Obtained from: https://github.com/saltstack/salt/pull/37772

NOTE: this was merged into 2016.3 tree, not into 2016.11 tree unfortunately.
Comment 1 Melvyn Sopacua 2016-12-02 14:37:12 UTC
Add Maintainer to CC after botching Product field earlier.
Comment 2 Christer Edwards 2016-12-04 20:29:54 UTC
I have submitted a patch for this here: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=215051
Comment 3 Melvyn Sopacua 2016-12-04 22:46:59 UTC
Great! Thanks for the fast response guys. Closing this as it's merged into the upgrade to 2016.11.

*** This bug has been marked as a duplicate of bug 215051 ***
Comment 4 commit-hook freebsd_committer 2016-12-05 15:01:36 UTC
A commit references this bug:

Author: swills
Date: Mon Dec  5 15:00:50 UTC 2016
New revision: 427901
URL: https://svnweb.freebsd.org/changeset/ports/427901

Log:
  sysutils/py-salt : update to 2016.3.4

  While here, fix OpenSSL 1.1 compatibility

  PR:		214786
  PR:		214998
  PR:		215051
  Submitted by:	Christer Edwards <christer.edwards@gmail.com> (maintainer)
  Reported by:	Melvyn Sopacua <m.r.sopacua@gmail.com> (214998)
  Obtained from:	https://github.com/saltstack/salt/pull/37772 (215051)

Changes:
  head/sysutils/py-salt/Makefile
  head/sysutils/py-salt/distinfo
  head/sysutils/py-salt/files/patch-freebsd_sysctl.py
  head/sysutils/py-salt/files/patch-salt_utils_rsax931.py
  head/sysutils/py-salt/files/patch-setup.py
  head/sysutils/py-salt/pkg-plist