Bug 215051 - sysutils/py-salt : fix #214998
Summary: sysutils/py-salt : fix #214998
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
: 214998 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-04 20:22 UTC by Christer Edwards
Modified: 2016-12-05 15:03 UTC (History)
2 users (show)

See Also:


Attachments
patch (2.07 KB, text/plain)
2016-12-04 20:22 UTC, Christer Edwards
christer.edwards: maintainer-approval+
Details
QA (poudriere testport) (504.51 KB, text/plain)
2016-12-04 20:25 UTC, Christer Edwards
christer.edwards: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christer Edwards 2016-12-04 20:22:33 UTC
Created attachment 177664 [details]
patch

This patches diff's off the 2016.11.0 revision here:

Fixes https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=214998
Upstream https://github.com/saltstack/salt/pull/37772
Comment 1 Christer Edwards 2016-12-04 20:25:02 UTC
Created attachment 177665 [details]
QA (poudriere testport)
Comment 2 Christer Edwards 2016-12-04 20:29:00 UTC
* https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=214786 (2016.11.0 update)
Comment 3 Melvyn Sopacua 2016-12-04 22:46:59 UTC
*** Bug 214998 has been marked as a duplicate of this bug. ***
Comment 4 commit-hook freebsd_committer 2016-12-05 15:01:38 UTC
A commit references this bug:

Author: swills
Date: Mon Dec  5 15:00:50 UTC 2016
New revision: 427901
URL: https://svnweb.freebsd.org/changeset/ports/427901

Log:
  sysutils/py-salt : update to 2016.3.4

  While here, fix OpenSSL 1.1 compatibility

  PR:		214786
  PR:		214998
  PR:		215051
  Submitted by:	Christer Edwards <christer.edwards@gmail.com> (maintainer)
  Reported by:	Melvyn Sopacua <m.r.sopacua@gmail.com> (214998)
  Obtained from:	https://github.com/saltstack/salt/pull/37772 (215051)

Changes:
  head/sysutils/py-salt/Makefile
  head/sysutils/py-salt/distinfo
  head/sysutils/py-salt/files/patch-freebsd_sysctl.py
  head/sysutils/py-salt/files/patch-salt_utils_rsax931.py
  head/sysutils/py-salt/files/patch-setup.py
  head/sysutils/py-salt/pkg-plist
Comment 5 Steve Wills freebsd_committer 2016-12-05 15:03:48 UTC
Committed, thanks!