Bug 215118 - editors/libreoffice: fails to build post 5.2 update
Summary: editors/libreoffice: fails to build post 5.2 update
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-07 14:07 UTC by Tom Judge
Modified: 2018-02-14 21:17 UTC (History)
6 users (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Judge freebsd_committer 2016-12-07 14:07:37 UTC
It has consistently failed unit tests when built in poudriere on 10.1 and 10.3 amd64. Since the 5.2 upgrade on November 12th by bapt@



tdf87348_linkedTextboxes.docx:
/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.2.3.3/sw/qa/extras/inc/swmodeltestbase.hxx:417:testTDF87348::Import_Export_Import
equality assertion failed
- Expected: 1
- Actual  : 0
- parsing dump failed

File tested,Execution Time (ms)
no-numlevel-but-indented.odt:
318
File tested,Execution Time (ms)
flip_and_rotate.odt:
152
swmodeltestbase.hxx:417:Assertion
Test name: testTDF87348::Import_Export_Import
equality assertion failed
- Expected: 1
- Actual  : 0
- parsing dump failed

Failures !!!
Run: 104   Failure total: 1   Failures: 1   Errors: 0

Error: a unit test failed, please do one of:
make CppunitTest_sw_ooxmlexport7 CPPUNITTRACE="gdb --args"
    # for interactive debugging on Linux
make CppunitTest_sw_ooxmlexport7 VALGRIND=memcheck
    # for memory checking
make CppunitTest_sw_ooxmlexport7 DEBUGCPPUNIT=TRUE
    # for exception catching

gmake[2]: *** [/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.2.3.3/solenv/gbuild/CppunitTest.mk:100: /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.2.3.3/workdir/CppunitTest/sw_ooxmlexport7.test] Error 1
gmake[2]: Leaving directory '/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.2.3.3'
gmake[1]: *** [Makefile:258: build] Error 2
gmake[1]: Leaving directory '/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.2.3.3'
*** Error code 1

Stop.
make: stopped in /usr/ports/editors/libreoffice
====>> Cleaning up wrkdir
===>  Cleaning for libreoffice-5.2.3_5
Comment 1 Matthias Fechner freebsd_committer 2016-12-12 19:40:15 UTC
Same problem here.
Build log can be found here:
https://pkg.fechner.net/data/110amd64-default/2016-12-10_10h56m41s/logs/errors/libreoffice-5.2.3_5.log
Comment 2 Matthias Fechner freebsd_committer 2016-12-12 20:04:26 UTC
Same problem with a compile of today:
https://pkg.fechner.net/data/110amd64-default/2016-12-12_20h02m17s/logs/errors/libreoffice-5.2.3_5.log
Comment 3 rainer 2017-01-04 08:18:43 UTC
It also does not build on 11.0 (AMD64), with 2017Q1 ports-tree as of yesterday.





File tested,Execution Time (ms)
tdf36117_verticalAdjustment.docx:
429
File tested,Execution Time (ms)
tdf87348_linkedTextboxes.docx:
138
File tested,Execution Time (ms)
tdf87348_linkedTextboxes.docx:
/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.2.4.2/sw/qa/extras/inc/swmodeltestbase.hxx:417:testTDF87348::Import_Export_Import
equality assertion failed
- Expected: 1
- Actual  : 0
- parsing dump failed

File tested,Execution Time (ms)
no-numlevel-but-indented.odt:
517
File tested,Execution Time (ms)
flip_and_rotate.odt:
210
File tested,Execution Time (ms)
tdf103389.docx:
101
File tested,Execution Time (ms)
tdf103389.docx:
277
File tested,Execution Time (ms)
tdf95031.docx:
129
File tested,Execution Time (ms)
tdf95031.docx:
316
File tested,Execution Time (ms)
tdf103573.docx:
145
File tested,Execution Time (ms)
tdf103573.docx:
290
File tested,Execution Time (ms)
tdf103544.docx:
102
File tested,Execution Time (ms)
tdf103544.docx:
230
swmodeltestbase.hxx:417:Assertion
Test name: testTDF87348::Import_Export_Import
equality assertion failed
- Expected: 1
- Actual  : 0
- parsing dump failed

Failures !!!
Run: 114   Failure total: 1   Failures: 1   Errors: 0

Error: a unit test failed, please do one of:
make CppunitTest_sw_ooxmlexport7 CPPUNITTRACE="gdb --args"
    # for interactive debugging on Linux
make CppunitTest_sw_ooxmlexport7 VALGRIND=memcheck
    # for memory checking
make CppunitTest_sw_ooxmlexport7 DEBUGCPPUNIT=TRUE
    # for exception catching

gmake[2]: *** [/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.2.4.2/solenv/gbuild/CppunitTest.mk:100: /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.2.4.2/workdir/CppunitTest/sw_ooxmlexport7.test] Error 1
gmake[2]: Leaving directory '/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.2.4.2'
gmake[1]: *** [Makefile:258: build] Error 2
gmake[1]: Leaving directory '/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.2.4.2'
*** Error code 1

Stop.
make: stopped in /usr/ports/editors/libreoffice
====>> Cleaning up wrkdir
===>  Cleaning for libreoffice-5.2.4
build of editors/libreoffice ended at Tue Jan  3 23:50:12 CET 2017
build time: 06:38:28
!!! build failure encountered !!!
Comment 4 rainer 2017-04-03 01:59:07 UTC
Still the same error with 5.2.6 in 2017Q2
Comment 5 Kurt Jaeger freebsd_committer 2017-04-23 17:29:56 UTC
I have one build host where I see the same problem and one, where I do not see that problem (!)
Comment 6 Kurt Jaeger freebsd_committer 2017-04-23 17:52:24 UTC
The working buildhost runs 12a, the jail is 11.0p1-amd64.
The failing buildhost runs 11a, the jail is 11.0p1-amd64.

makeoptions: identical, except: working has ruby=2.3, failing has 2.4.

port options: identical, except: working has MMEDIA=off, failing has on.
Comment 7 Kurt Jaeger freebsd_committer 2017-04-24 04:43:56 UTC
Rebuild on the failing host with MMEDIA=off, builds fine. So it's MMEDIA.
Comment 8 Kurt Jaeger freebsd_committer 2017-04-24 17:56:43 UTC
Rebuild with additional KDE4 option, is fine as well.
Comment 9 rainer 2017-04-24 18:02:21 UTC
What does MMEDIA=off do, actually?

A customer needs libreoffice to convert (rather simple, I assume) word and excel documents in his PHP application.

No GUI is ever opened, and certainly no videos played in impress.
Comment 10 Kurt Jaeger freebsd_committer 2017-04-24 18:17:04 UTC
MMEDIA_DESC says: Enable multimedia backend for impress, to display videos etc in presentations. If you don't need it, don't use it.
Comment 11 rainer 2017-04-25 22:22:38 UTC
OK, I checked.

I've got everything off:

---Begin OPTIONS List---
===> The following configuration options are available for libreoffice-5.2.6:
     CUPS=off: CUPS printing system support
     GNOME=off: GNOME desktop environment support
     GTK2=off: GTK+ 2 GUI toolkit support
     GTK3=off: GTK+ 3 GUI toolkit support (experimental)
     JAVA=off: Add Java support (XML filters, macros)
     KDE4=off: KDE 4 desktop environment support
     MMEDIA=off: Enable multimedia backend for impress
     PGSQL=off: Build with PostgreSQL-SDBC driver
     SDK=off: Build with SDK
     SYSTRAY=off: Enable systemtray quickstarter
     TEST=off: Run all regression tests
     VERBOSE=off: Increase build verbosity
     WEBDAV=off: Enable webdav protocol
===> Use 'make config' to modify these settings
---End OPTIONS List---


The biggest problem I have is that every build takes well over 6h.
Comment 12 rainer 2017-06-02 00:02:01 UTC
I've now done a rebuild (using head) and making sure I had a "clean" build-environment.

I've removed all of my custom options from my ports (except for PHP70) and it still keeps failing.

====>> Building editors/libreoffice
build started at Thu Jun  1 15:28:57 CEST 2017
port directory: /usr/ports/editors/libreoffice
building for: FreeBSD 11_0-amd64-head-php70-mariadb101-job-04 11.0-RELEASE-p9 FreeBSD 11.0-RELEASE-p9 amd64
maintained by: office@FreeBSD.org
Makefile ident:      $FreeBSD: head/editors/libreoffice/Makefile 441503 2017-05-23 05:03:14Z rezny $
Poudriere version: 3.1.17
Host OSVERSION: 1100122
Jail OSVERSION: 1100122
Job Id: 04

---Begin Environment---
SHELL=/bin/csh
OSVERSION=1100122
UNAME_v=FreeBSD 11.0-RELEASE-p9
UNAME_r=11.0-RELEASE-p9
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=screen
MASTERMNT=/usr/local/poudriere/data/.m/11_0-amd64-head-php70-mariadb101/ref
FORCE_PACKAGE=yes
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=libreoffice-5.3.3_1
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/11_0-amd64-head-php70-mariadb101/ref/.p/pool
MASTERNAME=11_0-amd64-head-php70-mariadb101
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.17
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for libreoffice-5.3.3_1:
     CUPS=off: CUPS printing system support
     GNOME=off: GNOME desktop environment support
     GTK2=off: GTK+ 2 GUI toolkit support
     GTK3=off: GTK+ 3 GUI toolkit support (experimental)
     JAVA=off: Add Java support (XML filters, macros)
     KDE4=off: KDE 4 desktop environment support
     MMEDIA=off: Enable multimedia backend for impress
     PGSQL=off: Build with PostgreSQL-SDBC driver
     SDK=off: Build with SDK
     SYSTRAY=off: Enable systemtray quickstarter
     TEST=off: Run all regression tests
     VERBOSE=off: Increase build verbosity
     WEBDAV=off: Enable webdav protocol
===> Use 'make config' to modify these settings
---End OPTIONS List---



...


---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/11_0-amd64-head-php70-mariadb101-make.conf ####
WITH_PKGNG=yes
INSTALL_NODEBUG="yes"
A4=yes
WITH_UTF8=yes
WITHOUT_X11=yes
WITHOUT_X=yes
OPTIONS_UNSET="X11 DOCS"

NO_PROFILE=true
WITH_MPM=event 
WANT_OPENLDAP_SASL=YES
WITH_GSSAPI=YES


#APACHE_PORT=www/apache24
DEFAULT_VERSIONS+=php=7.0 mysql=10.1m apache=2.4 ruby=2.3 pgsql=9.6 perl5=5.24 python=2.7



I'm now trying a run with X11 enable.
Comment 13 rainer 2017-06-02 12:50:15 UTC
Hm. Still no build.


Fails at the same position every time:

testTdf106001_2::Import_Export_Import finished in: 184ms
File tested,Execution Time (ms)
tdf103931.docx:
57
testTdf103931::Import finished in: 64ms
File tested,Execution Time (ms)
tdf103931.docx:
125
testTdf103931::Import_Export_Import finished in: 131ms
ooxmlexport9.cxx:85:Assertion
Test name: testTdf41542_borderlessPadding::Import_Export_Import
equality assertion failed
- Expected: 3
- Actual  : 2

Failures !!!
Run: 46   Failure total: 1   Failures: 1   Errors: 0

Error: a unit test failed, please do one of:
make CppunitTest_sw_ooxmlexport9 CPPUNITTRACE="gdb --args"
    # for interactive debugging on Linux
make CppunitTest_sw_ooxmlexport9 VALGRIND=memcheck
    # for memory checking
make CppunitTest_sw_ooxmlexport9 DEBUGCPPUNIT=TRUE
    # for exception catching

gmake[2]: *** [/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.3.3.2/solenv/gbuild/CppunitTest.mk:102: /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.3.3.2/workdir/CppunitTest/sw_ooxmlexport9.test] Error 1
gmake[2]: Leaving directory '/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.3.3.2'
gmake[1]: *** [Makefile:265: build] Error 2
gmake[1]: Leaving directory '/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-5.3.3.2'
*** Error code 1

Stop.
make: stopped in /usr/ports/editors/libreoffice
====>> Cleaning up wrkdir
===>  Cleaning for libreoffice-5.3.3_1
build of editors/libreoffice ended at Fri Jun  2 14:21:58 CEST 2017
build time: 07:02:20
!!! build failure encountered !!!



Does anyone know what exactly it is missing there?
Comment 14 Jung-uk Kim freebsd_committer 2017-06-07 23:00:30 UTC
I turned off all unit test by default, i.e., r442891.  It should work around your build issues.
Comment 15 rainer 2017-06-08 06:21:14 UTC
Thanks.

Recently (day before yesterday), I discovered that with default options, it builds!

Seems I only had problems because I switched off everything.
Comment 16 Walter Schwarzenfeld freebsd_triage 2018-02-14 21:17:23 UTC
See comment15, not a bug.