Bug 215162 - lang/ruby22 During install, pkg-static Fail to create temporary file File Exists
Summary: lang/ruby22 During install, pkg-static Fail to create temporary file File Exists
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ruby (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2016-12-08 21:48 UTC by drhowarddrfine
Modified: 2016-12-27 07:45 UTC (History)
4 users (show)

See Also:
vlad-fbsd: maintainer-feedback? (ruby)
vlad-fbsd: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description drhowarddrfine 2016-12-08 21:48:34 UTC
Trying to upgrade ruby to 2.2.6_1,1 on FreeBSD 11.0-RELEASE-p4. When it failed the first time, I was left with no ruby installation at all. Did 'make clean' then reinstalled with portmaster which also ended the same way:

===>  Installing for ruby-2.2.6_1,1
===>  Checking if ruby already installed
===>   Registering installation for ruby-2.2.6_1,1
Installing ruby-2.2.6_1,1...
pkg-static: Fail to create temporary file: /usr/local/share/ri/2.2/system/ObjectSpace/.trace_object_allocations_start-c.ri.ZfTr7VgAc6WN: File exists
*** Error code 70

Stop.
make[1]: stopped in /usr/ports/lang/ruby22
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/ruby22

===>>> Installation of ruby-2.2.6_1,1 (lang/ruby22) failed
===>>> Aborting update
Comment 1 VK freebsd_triage 2016-12-11 16:44:14 UTC
Assigning to ruby@ properly after summary correction with proper port name.
Comment 2 Andrej 2016-12-21 22:24:20 UTC
What is the solution? the same error
9.3-RELEASE-p43
Comment 3 Steve Wills freebsd_committer 2016-12-26 18:03:50 UTC
What version of pkg is in use?
Comment 4 Andrej 2016-12-26 19:37:23 UTC
pkg-1.9.4
Now with the pkg-1.9.4_1 version of the error does not appear
Comment 5 drhowarddrfine 2016-12-26 21:29:55 UTC
I believe the problem was caused by an out-of-date portsnap server, sourcefire. As I was accumulating a number of ports that would not update, I changed servers and then lang/ruby22 also updated. 

Since I opened this ticket, I don't know if I should close it since others have reported the same issue. I wouldn't know if theirs was caused by the same thing.
Comment 6 Matthew Seaman freebsd_committer 2016-12-26 22:39:34 UTC
This is a file descriptor leak in pkg(8) -- it's not ruby specific.

Fixed in git by: https://github.com/freebsd/pkg/commit/6724cf95c993fd7e541def65ccc7c1fca3eca2de
Comment 7 Steve Wills freebsd_committer 2016-12-26 23:00:31 UTC
Closing, not a ruby bug. Thanks for the info Matthew.
Comment 8 Baptiste Daroussin freebsd_committer 2016-12-27 07:45:04 UTC
Note that this is fixed in pkg 1.9.4_1