Bug 215178 - sysutils/rubygem-fluentd: Requires string-scrub gem on FreeBSD 11.0-RELEASE (ruby2.2) when it is only needed for ruby version prior to 2.0
Summary: sysutils/rubygem-fluentd: Requires string-scrub gem on FreeBSD 11.0-RELEASE (...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jun Kuriyama
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-09 13:08 UTC by Yanis Guenane
Modified: 2017-01-06 23:07 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (kuriyama)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yanis Guenane 2016-12-09 13:08:13 UTC
The port sysutils/rubygem-fluentd does not work out of the box. It has a hard dependency on string-scrub[1], that cannot be installed on FreeBSD 11.0-RELEASE due to the version of ruby installed.

FreeBSD 11.0-RELEASE runs ruby 2.2, while string-scrub was only used for OS that runs ruby version prior to 2.1.

Installation process:

> #> pkg install rubygem-fluentd
> #> gem install tzinfo-data
> #> fluentd --version
> /usr/local/lib/ruby/site_ruby/2.2/rubygems/dependency.rb:308:in `to_specs': Could not find 'string-scrub' (>= 0.0.3) among 15 total gem(s) (Gem::MissingSpecError)
> Checked in 'GEM_PATH=/root/.gem/ruby/2.2:/usr/local/lib/ruby/gems/2.2', execute `gem env` for more information
>        from /usr/local/lib/ruby/site_ruby/2.2/rubygems/specification.rb:1439:in `block in activate_dependencies'
>        from /usr/local/lib/ruby/site_ruby/2.2/rubygems/specification.rb:1428:in `each'
>        from /usr/local/lib/ruby/site_ruby/2.2/rubygems/specification.rb:1428:in `activate_dependencies'
>        from /usr/local/lib/ruby/site_ruby/2.2/rubygems/specification.rb:1410:in `activate'
>        from /usr/local/lib/ruby/site_ruby/2.2/rubygems.rb:279:in `block in activate_bin_path'
>        from /usr/local/lib/ruby/site_ruby/2.2/rubygems.rb:279:in `synchronize'
>        from /usr/local/lib/ruby/site_ruby/2.2/rubygems.rb:279:in `activate_bin_path'
>        from /usr/local/bin/fluent-gem:22:in `<main>'

If I edit the rubygem-fluentd gemspec file (/usr/local/lib/ruby/gems/2.2/specifications/fluentd-0.12.14.gemspec) and remove the reference to string-scrub

> #> fluentd --version
> #> fluentd 0.12.14

[1] https://rubygems.org/gems/string-scrub
Comment 1 commit-hook freebsd_committer 2017-01-06 22:51:22 UTC
A commit references this bug:

Author: swills
Date: Fri Jan  6 22:50:43 UTC 2017
New revision: 430755
URL: https://svnweb.freebsd.org/changeset/ports/430755

Log:
  sysutils/rubygem-fluentd: Patch to remove dep on string-scrub

  PR:		215178
  Reported by:	Yanis Guenane <yanis+freebsd@guenane.org>
  Approved by:	maintainer timeout (kuriyama, >4 weeks)
  MFH:		2017Q1

Changes:
  head/sysutils/rubygem-fluentd/Makefile
  head/sysutils/rubygem-fluentd/files/patch-fluent.conf.sample
  head/sysutils/rubygem-fluentd/files/patch-fluentd.gemspec
Comment 2 Steve Wills freebsd_committer 2017-01-06 22:52:35 UTC
Patch to remove dep from gemspec committed, thanks for the report.
Comment 3 commit-hook freebsd_committer 2017-01-06 23:07:36 UTC
A commit references this bug:

Author: swills
Date: Fri Jan  6 23:06:54 UTC 2017
New revision: 430756
URL: https://svnweb.freebsd.org/changeset/ports/430756

Log:
  MFH: r430755

  sysutils/rubygem-fluentd: Patch to remove dep on string-scrub

  PR:		215178
  Reported by:	Yanis Guenane <yanis+freebsd@guenane.org>
  Approved by:	maintainer timeout (kuriyama, >4 weeks)

Changes:
_U  branches/2017Q1/
  branches/2017Q1/sysutils/rubygem-fluentd/Makefile
  branches/2017Q1/sysutils/rubygem-fluentd/files/patch-fluent.conf.sample
  branches/2017Q1/sysutils/rubygem-fluentd/files/patch-fluentd.gemspec