Bug 215211 - devel/include-what-you-use : update to 0.7
Summary: devel/include-what-you-use : update to 0.7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rene Ladan
URL:
Keywords: patch-ready
Depends on:
Blocks:
 
Reported: 2016-12-11 11:46 UTC by Rene Ladan
Modified: 2018-08-05 23:33 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (koobs)


Attachments
patch for version 0.7 (2.74 KB, patch)
2016-12-11 11:46 UTC, Rene Ladan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Ladan freebsd_committer 2016-12-11 11:46:00 UTC
Created attachment 177867 [details]
patch for version 0.7

Update devel/include-what-you-use to version 0.7, which supports clang 3.9, adds mappings for Qt 5.4 and various other fixes and enhancements.

This update introduces pkg-plist.

Builds fine in poudriere on 10.1-i386 and 12.0-amd64
Comment 1 Rene Ladan freebsd_committer 2016-12-27 12:16:43 UTC
Timeout, committed
Comment 2 commit-hook freebsd_committer 2016-12-27 12:17:36 UTC
A commit references this bug:

Author: rene
Date: Tue Dec 27 12:16:32 UTC 2016
New revision: 429611
URL: https://svnweb.freebsd.org/changeset/ports/429611

Log:
  devel/include-what-you-use: update to version 0.7

  - now uses clang 3.9 instead of clang 3.7
  - add mappings for Qt 5.4
  - premilinary mapings for libc++
  - bugfix in fix_incudes.py
  - various other fixes and enhancements
  - add pkg-plist

  PR:		215211
  Submitted by:	rene
  Approved by:	maintainer timeout (koobs, 16 days)

Changes:
  head/devel/include-what-you-use/Makefile
  head/devel/include-what-you-use/distinfo
  head/devel/include-what-you-use/pkg-plist
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2018-08-05 23:33:37 UTC
Correctly assign to committer that resolved