Bug 215230 - devel/subversion: Fix shebang fix
Summary: devel/subversion: Fix shebang fix
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Lev A. Serebryakov
URL:
Keywords:
Depends on:
Blocks: 216309
  Show dependency treegraph
 
Reported: 2016-12-11 20:37 UTC by Xin LI
Modified: 2017-02-01 17:43 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (lev)


Attachments
Proposed fix (798 bytes, patch)
2016-12-11 20:37 UTC, Xin LI
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Xin LI freebsd_committer 2016-12-11 20:37:07 UTC
Created attachment 177887 [details]
Proposed fix

The build would fail on:

===>  Patching for subversion-1.9.5
===>  Applying extra patch /usr/ports/devel/subversion/files/extra-patch-fbsd-template
===>  Applying FreeBSD patches for subversion-1.9.5
sed: /tmp/usr/ports/devel/subversion/work/subversion-1.9.5/tools/dist/nominate.pl: in-place editing only works for regular files
*** Error code 1

The problem is that the port is not using the standard Uses/shebangfix.mk but instead used grep -R, which does not distinguish between regular file and symbolic links.

The proposed fix uses find(1) instead of using direct recursive grep.
Comment 1 Lev A. Serebryakov freebsd_committer 2017-02-01 17:42:54 UTC
Committed, thanks!
Comment 2 commit-hook freebsd_committer 2017-02-01 17:43:30 UTC
A commit references this bug:

Author: lev
Date: Wed Feb  1 17:42:41 UTC 2017
New revision: 433059
URL: https://svnweb.freebsd.org/changeset/ports/433059

Log:
   Fix shebang fix for new sed(1) behavior

  PR:		215230
  Submitted by:	Xin Li <delphij@FreeBSD.org>

Changes:
  head/devel/subversion/Makefile.common
  head/devel/subversion18/Makefile.common