Bug 215300 - deskutils/gnome-maps: is missing the net/gfbgraph dependency
Summary: deskutils/gnome-maps: is missing the net/gfbgraph dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-14 12:29 UTC by vermaden
Modified: 2018-05-24 16:59 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
patch to add missing dep (648 bytes, patch)
2018-04-16 03:42 UTC, Steve Wills
no flags Details | Diff
patch to add missing dep2 and sort deps (1.21 KB, patch)
2018-04-16 17:43 UTC, Steve Wills
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description vermaden 2016-12-14 12:29:45 UTC
# pkg install gnome-maps
Updating FreeBSD repository catalogue...
FreeBSD repository is up-to-date.
All repositories are up-to-date.
Updating database digests format: 100%

The following 15 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        gnome-maps: 3.18.4
        cogl: 1.22.0
        clutter: 1.24.2
        folks: 0.11.1
        libsocialweb: 0.25.21_3
        evolution-data-server: 3.18.5_5
        libical: 1.0.1
        libgweather: 3.18.2
        geocode-glib: 3.18.2
        zeitgeist: 0.9.16
        py27-xdg: 0.25
        gjs: 1.44.0
        spidermonkey24: 24.2.0_2
        libchamplain: 0.12.13
        clutter-gtk3: 1.6.6

Number of packages to be installed: 15

The process will require 90 MiB more space.
12 MiB to be downloaded.

Proceed with this action? [y/N]: y
(...)
# 



% gnome-maps
Unsatisfied dependency: Requiring GFBGraph, version 0.2: Typelib file for namespace 'GFBGraph', version '0.2' not found

# pkg install gfbgraph
(...)
# 
 
% gnome-maps
[WORKS]
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-01-13 02:28:03 UTC
Maintainer feedback, please!
Comment 2 Steve Wills freebsd_committer 2018-04-16 03:42:23 UTC
Created attachment 192543 [details]
patch to add missing dep

Please see attached
Comment 3 Ting-Wei Lan 2018-04-16 15:03:46 UTC
It looks like gnome-online-accounts is also missing:

:: src/main.js

pkg.require({ 'cairo': '1.0',
              'Champlain': '0.12',
              'Clutter': '1.0',
              'Cogl': '1.0',
              'GeocodeGlib': '1.0',
              'Gdk': '3.0',
              'GdkPixbuf': '2.0',
              'GFBGraph': '0.2',
              'Gio': '2.0',
              'GLib': '2.0',
              'Goa': '1.0',
              'GObject': '2.0',
              'Gtk': '3.0',
              'GtkChamplain': '0.12',
              'GtkClutter': '1.0',
              'Rest': '0.7',
              'Soup': '2.4' });
Comment 4 Steve Wills freebsd_committer 2018-04-16 17:43:53 UTC
Created attachment 192564 [details]
patch to add missing dep2 and sort deps

Please see attached
Comment 5 Ting-Wei Lan 2018-04-17 15:52:34 UTC
Attachment 192564 [details] looks good to me though I am not a maintainer.
Comment 6 vermaden 2018-05-24 09:02:43 UTC
Can I close that now?
Comment 7 Walter Schwarzenfeld freebsd_triage 2018-05-24 09:59:41 UTC
Test it! The problem still exists.
Comment 8 Walter Schwarzenfeld freebsd_triage 2018-05-24 10:08:37 UTC
Needs only to comitted.
Comment 9 commit-hook freebsd_committer 2018-05-24 16:56:36 UTC
A commit references this bug:

Author: swills
Date: Thu May 24 16:55:59 UTC 2018
New revision: 470791
URL: https://svnweb.freebsd.org/changeset/ports/470791

Log:
  deskutils/gnome-maps: add missing net/gfbgraph dependency

  PR:		215300
  Reported by:	vermaden@interia.pl
  Approved by:	maintainer timeout (gnome@FreeBSD.org, >1 month)

Changes:
  head/deskutils/gnome-maps/Makefile
Comment 10 Steve Wills freebsd_committer 2018-05-24 16:59:21 UTC
Fix committed, let me know if you have issues.