Bug 215345 - www/linux-c6-flashplugin24: After update from linux-flashplugin11 to 24.0.0.186, it always crashes nspluginwrapper
Summary: www/linux-c6-flashplugin24: After update from linux-flashplugin11 to 24.0.0.1...
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-emulation mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-16 17:33 UTC by Dimitry Andric
Modified: 2017-01-13 02:41 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (emulation)


Attachments
Xorg.0.log (10.90 KB, text/plain)
2016-12-19 19:52 UTC, Chris
no flags Details
Xorg.0.log (10.43 KB, text/x-log)
2016-12-20 10:21 UTC, Chen Xie
no flags Details
glxinfo output (53.08 KB, text/plain)
2016-12-20 10:28 UTC, Chen Xie
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitry Andric freebsd_committer 2016-12-16 17:33:52 UTC
Just updated from a known working linux-c6-flashplugin-11.2r202.644 to linux-c6-flashplugin-24.0.0.186 on FreeBSD 11.0-STABLE r309548 amd64, and the plugin is now consistently crashing npviewer.bin from nspluginwrapper:

$ firefox
Vector smash protection is enabled.
*** NSPlugin Wrapper *** ERROR: NPP_GetValue() invoke: Broken pipe
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2219):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2219):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2848):invoke_NPP_HandleEvent: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2219):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2478):invoke_NPP_NewStream: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2219):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2219):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2848):invoke_NPP_HandleEvent: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2848):invoke_NPP_HandleEvent: assertion failed: (rpc_method_invoke_possible(plugin->connection))
Vector smash protection is enabled.
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Broken pipe
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2848):invoke_NPP_HandleEvent: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2848):invoke_NPP_HandleEvent: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2848):invoke_NPP_HandleEvent: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2848):invoke_NPP_HandleEvent: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2150):invoke_NPP_Destroy: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2269):invoke_NPP_GetValue: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2269):invoke_NPP_GetValue: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2150):invoke_NPP_Destroy: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2150):invoke_NPP_Destroy: assertion failed: (rpc_method_invoke_possible(plugin->connection))

(This is with Adobe's "About Flash" test page.)

Reverting back to linux-c6-flashplugin-11.2r202.644 makes it work fine again.  Unfortunately neither base gdb nor ports gdb can debug the npviewer.bin.core file, as it is a 32-bit core file, apparently.

Any idea how to further debug this?
Comment 1 Tijl Coosemans freebsd_committer 2016-12-16 18:00:57 UTC
Are linux_base-c6 and other linux-c6-* ports up to date?
What is the output of '/compat/linux/bin/sh ldd /usr/local/lib/browser_plugins/linux-c6-flashplugin/libflashplayer.so'?
Comment 2 Dimitry Andric freebsd_committer 2016-12-16 18:10:23 UTC
(In reply to Tijl Coosemans from comment #1)
> Are linux_base-c6 and other linux-c6-* ports up to date?

As far I can tell, yes.  The packages were all built by poudriere off a head r428633 ports tree:

linux-c6-alsa-lib-1.1.0
linux-c6-alsa-plugins-oss-1.1.0
linux-c6-atk-1.30.0
linux-c6-cairo-1.8.8_6
linux-c6-curl-7.19.7_8
linux-c6-cyrus-sasl2-2.1.23_3
linux-c6-dri-11.0.7_3
linux-c6-expat-2.0.1_3
linux-c6-flashplugin-24.0.0.186
linux-c6-fontconfig-2.8.0_1
linux-c6-gdk-pixbuf2-2.24.1_3
linux-c6-gtk2-2.24.23_5
linux-c6-jasper-1.900.1_1
linux-c6-jpeg-1.2.1_1
linux-c6-libelf-0.164
linux-c6-libpciaccess-0.13.4_1
linux-c6-libssh2-1.4.2_5
linux-c6-libthai-0.1.12
linux-c6-nspr-4.11.0
linux-c6-nss-3.21.3
linux-c6-openldap-2.4.40_2
linux-c6-openssl-1.0.1e_11
linux-c6-openssl-compat-0.9.8e_4
linux-c6-pango-1.28.1_6
linux-c6-pixman-0.32.8
linux-c6-png-1.2.49_3
linux-c6-sqlite-3.6.20_3
linux-c6-tiff-3.9.4_2
linux-c6-xorg-libs-7.4_6
linux_base-c6-6.8_6


> What is the output of '/compat/linux/bin/sh ldd
> /usr/local/lib/browser_plugins/linux-c6-flashplugin/libflashplayer.so'?

$ /compat/linux/bin/sh ldd /usr/local/lib/browser_plugins/linux-c6-flashplugin/libflashplayer.so
ldd: warning: you do not have execution permission for `/usr/local/lib/browser_plugins/linux-c6-flashplugin/libflashplayer.so'
	linux32_vdso.so.1 =>  (0xffffe000)
	libGL.so.1 => /usr/lib/libGL.so.1 (0x21024000)
	libdl.so.2 => /lib/libdl.so.2 (0x210cd000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x210d2000)
	librt.so.1 => /lib/librt.so.1 (0x210ed000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x22306000)
	libXt.so.6 => /usr/lib/libXt.so.6 (0x210f7000)
	libnss3.so => /usr/lib/libnss3.so (0x22440000)
	libsmime3.so => /usr/lib/libsmime3.so (0x21153000)
	libssl3.so => /usr/lib/libssl3.so (0x2117e000)
	libnspr4.so => /lib/libnspr4.so (0x211c0000)
	libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x22600000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x22aa9000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x2257e000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x2259e000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x22b64000)
	libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x22b99000)
	libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x22be6000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x22d03000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x22d9c000)
	libm.so.6 => /lib/libm.so.6 (0x22e87000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x22eb1000)
	libc.so.6 => /lib/libc.so.6 (0x22ecf000)
	libglapi.so.0 => /usr/lib/libglapi.so.0 (0x23067000)
	libselinux.so.1 => /lib/libselinux.so.1 (0x230b4000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x225e8000)
	libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x225fa000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x230d3000)
	libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0x225fe000)
	libxcb-glx.so.0 => /usr/lib/libxcb-glx.so.0 (0x230d8000)
	libxcb-dri2.so.0 => /usr/lib/libxcb-dri2.so.0 (0x230f0000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x230f5000)
	libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0x23117000)
	libdrm.so.2 => /usr/lib/libdrm.so.2 (0x2311d000)
	libexpat.so.1 => /lib/libexpat.so.1 (0x2312b000)
	/lib/ld-linux.so.2 (0x01001000)
	libSM.so.6 => /usr/lib/libSM.so.6 (0x23153000)
	libICE.so.6 => /usr/lib/libICE.so.6 (0x2315b000)
	libnssutil3.so => /usr/lib/libnssutil3.so (0x23175000)
	libplc4.so => /lib/libplc4.so (0x2319b000)
	libplds4.so => /lib/libplds4.so (0x231a2000)
	libz.so.1 => /lib/libz.so.1 (0x231a7000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x231bb000)
	libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x231c7000)
	libcairo.so.2 => /usr/lib/libcairo.so.2 (0x231e6000)
	libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0x23267000)
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x2338b000)
	libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x233b5000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0x233b9000)
	libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x233c2000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0x233c6000)
	libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x233d5000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x233df000)
	libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x233e9000)
	libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x233ec000)
	libpng12.so.0 => /usr/lib/libpng12.so.0 (0x233f2000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x2341a000)
	libuuid.so.1 => /lib/libuuid.so.1 (0x2341d000)
	libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x23422000)
	libresolv.so.2 => /lib/libresolv.so.2 (0x234ce000)

Additional info:

/usr/local/lib/browser_plugins/linux-c6-flashplugin/libflashplayer.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, BuildID[sha1]=4097a378af9fa53585a629464109b446a2cc865d, stripped
Comment 3 Masachika ISHIZUKA 2016-12-17 00:11:31 UTC
I have the same problem.
Opera and firefox does not work with linux-c6-flashplugin24.
Firefox can be worked flash 24.0.0.186 with wine (install emulators/pipelight
and edit /usr/local/share/pipelight/install-dependency line 918-920 to 24.0.0.186. i.e. INS=(install_flash "24_0_0_186")\n URL="http://fpdownload.macromedia.com/get/flashplayer/pdc/24.0.0.186/install_flash_player.exe"\n SHA="e8b580285fa01bd64e06bf485247dd23c0c87eb551d5e9a7f3d
ae15712d9a4a7"\n).
Comment 4 Tijl Coosemans freebsd_committer 2016-12-17 00:35:37 UTC
Here it just works in Firefox.  You ran "nspluginwrapper -v -a -u" right?
Comment 5 Masachika ISHIZUKA 2016-12-17 05:21:49 UTC
(In reply to Tijl Coosemans from comment #4)

Yes. I did. But it doesn't work both on 11.0-RELEASE-p5 amd64 and 12-CURRENT  r310132 amd64.
Comment 6 Tijl Coosemans freebsd_committer 2016-12-17 11:27:08 UTC
(In reply to Masachika ISHIZUKA from comment #5)
Running nspluginwrapper doesn't work?  Try removing ~/.mozilla/plugins/npwrapper.libflashplayer.so and run "nspluginwrapper -v -a -i".
Comment 7 Dimitry Andric freebsd_committer 2016-12-17 13:09:30 UTC
(In reply to Tijl Coosemans from comment #6)
> (In reply to Masachika ISHIZUKA from comment #5)
> Running nspluginwrapper doesn't work?  Try removing
> ~/.mozilla/plugins/npwrapper.libflashplayer.so and run "nspluginwrapper -v
> -a -i".

I had already tried that, but it didn't help.  I even tried completely removing and rebuilding nspluginwrapper, but that didn't help either.
Comment 8 Tijl Coosemans freebsd_committer 2016-12-17 15:50:36 UTC
In Firefox->Tools->Add-ons->Plugins does it say version 24 for flash or still 11?
Is there an npwrapper.* file in /usr/local/lib/browser_plugins or one of its subdirectories?
Does /compat/linux/usr/lib/libflashsupport.so still exist?  If so, remove it.
Comment 9 Dimitry Andric freebsd_committer 2016-12-17 16:15:20 UTC
(In reply to Tijl Coosemans from comment #8)
> In Firefox->Tools->Add-ons->Plugins does it say version 24 for flash or
> still 11?

It correctly says "Shockwave Flash 24.0 r0", "Last Updated: 12/16/16", "File: npwrapper.libflashplayer.so".  

about:plugins has similar information:

Shockwave Flash

    File: npwrapper.libflashplayer.so
    Path: /home/dim/.mozilla/plugins/npwrapper.libflashplayer.so
    Version: 
    State: Enabled
    Shockwave Flash 24.0 r0

MIME Type	Description	Suffixes
application/x-shockwave-flash	Shockwave Flash	swf
application/futuresplash	FutureSplash Player	spl


> Is there an npwrapper.* file in /usr/local/lib/browser_plugins or one of its
> subdirectories?

No.  There is only a file:

/usr/local/lib/browser_plugins/linux-c6-flashplugin/libflashplayer.so

and a number of symlinks, which all point to that file:

/usr/local/lib/browser_plugins/symlinks/linux-firefox/libflashplayer.so
/usr/local/lib/browser_plugins/symlinks/linux-opera-devel/libflashplayer.so
/usr/local/lib/browser_plugins/symlinks/linux-opera/libflashplayer.so
/usr/local/lib/browser_plugins/symlinks/linux-seamonkey/libflashplayer.so


> Does /compat/linux/usr/lib/libflashsupport.so still exist?  If so, remove it.

There exists only a dangling symlink libflashsupport.so.0, which used to point to libflashsupport.so, but that file is no longer there.

I have cleaned up the dangling symlink, but the plugin still crashes in a similar manner.

I will try it with the CentOS 7 based Linux packages now.
Comment 10 Dimitry Andric freebsd_committer 2016-12-17 16:25:20 UTC
> I will try it with the CentOS 7 based Linux packages now.

Huh, this is just very weird.  linux-c7-flashplugin does not even depend on nspluginwrapper, so it can't run?  And nspluginwrapper hard-depends on the CentOS6 Linux compat packages?  Is this supposed to work at all? :-)
Comment 11 Dimitry Andric freebsd_committer 2016-12-17 16:31:28 UTC
Actually, none of the flashplayer ports depend on nspluginwrapper, so they don't run by default, at all. :(
Comment 12 Dimitry Andric freebsd_committer 2016-12-17 16:54:47 UTC
Okay, I think the mystery is solved.  This new version of flash player absolutely requires /compat/linux/proc, or it will crash immediately.

E.g. adding the following line to /etc/fstab:

linprocfs /compat/linux/proc linprocfs rw 0 0

and mounting /compat/linux/proc makes the plugin work.

I guess the linux-base port already tells you this, but it only says "some programs" need it, not specifically which ones.  And the flash plug has never required it until now.

So maybe adding a warning to the pkg-message for linux-flashplugin would be nice?

Ishizuka-san, can you please also confirm that adding /compat/linux/proc makes the plugin work for you?
Comment 13 Masachika ISHIZUKA 2016-12-18 06:09:53 UTC
(In reply to Dimitry Andric from comment #12)

Thank you very much.
After mounting linux procfs, flash 24.0.0.186 works well both on opare and firefox.
It's woderful!

# I'm sorry that the reply was late because I was out.
Comment 14 Dimitry Andric freebsd_committer 2016-12-18 12:07:11 UTC
Let's close this as Not A Bug then. I'd still think it would be nice to add an explicit message to the port, but that is up to the maintainer.
Comment 15 Chen Xie 2016-12-18 13:46:27 UTC
(In reply to Dimitry Andric from comment #0)

I have already mounted linprocfs, and got the same message on 11.0-Release-p5-amd64.

Filesystem                    Size    Used   Avail Capacity  Mounted on
zroot/ROOT/default            814G     13G    801G     2%    /
devfs                         1.0K    1.0K      0B   100%    /dev
fdescfs                       1.0K    1.0K      0B   100%    /dev/fd
procfs                        4.0K    4.0K      0B   100%    /proc
linprocfs                     4.0K    4.0K      0B   100%    /compat/linux/proc

additional crash message:
Vector smash protection is enabled.
*** NSPlugin Wrapper *** ERROR: NPClass::HasProperty() invoke: Broken pipe
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6c0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6c0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6c0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6c0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6c0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6c0 is no longer valid!

ldd outpout:
        linux32_vdso.so.1 =>  (0xffffe000)
        libGL.so.1 => /usr/lib/libGL.so.1 (0x21025000)
        libdl.so.2 => /lib/libdl.so.2 (0x21139000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x2113e000)
        librt.so.1 => /lib/librt.so.1 (0x21159000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x22306000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0x21163000)
        libnss3.so => /usr/lib/libnss3.so (0x22440000)
        libsmime3.so => /usr/lib/libsmime3.so (0x211bf000)
        libssl3.so => /usr/lib/libssl3.so (0x2257e000)
        libnspr4.so => /lib/libnspr4.so (0x225c0000)
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x22600000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x22aa9000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x22b64000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x22b84000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x22bcd000)
        libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x22c02000)
        libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x22c4f000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x22d6c000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x22e05000)
        libm.so.6 => /lib/libm.so.6 (0x22ef0000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x22f1a000)
        libc.so.6 => /lib/libc.so.6 (0x22f38000)
        libnvidia-tls.so.367.44 => /usr/lib/libnvidia-tls.so.367.44 (0x211ed000)
        libnvidia-glcore.so.367.44 => /usr/lib/libnvidia-glcore.so.367.44 (0x23200000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x230d0000)
        /lib/ld-linux.so.2 (0x01001000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x230e2000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0x211f2000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0x23104000)
        libnssutil3.so => /usr/lib/libnssutil3.so (0x2311e000)
        libplc4.so => /lib/libplc4.so (0x23144000)
        libplds4.so => /lib/libplds4.so (0x211fb000)
        libz.so.1 => /lib/libz.so.1 (0x2314a000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x2315e000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x2316a000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x2316f000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0x25556000)
        libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0x255d6000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x2318e000)
        libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x231b8000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0x231bc000)
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x231c5000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0x231c8000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x231d7000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x231e2000)
        libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x231ec000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x231ef000)
        libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x231f2000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0x256fa000)
        libexpat.so.1 => /lib/libexpat.so.1 (0x25722000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x231f8000)
        libuuid.so.1 => /lib/libuuid.so.1 (0x231fb000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x2574a000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x257f6000)
        libselinux.so.1 => /lib/libselinux.so.1 (0x25810000)
Comment 16 commit-hook freebsd_committer 2016-12-18 15:03:46 UTC
A commit references this bug:

Author: tijl
Date: Sun Dec 18 15:03:05 UTC 2016
New revision: 428854
URL: https://svnweb.freebsd.org/changeset/ports/428854

Log:
  - Combine linux-c6-flashplugin24 and linux-c7-flashplugin24 into one distro
    independent port like other Linux application ports.
  - Rename flashplugin to flashplayer to match upstream.
  - Tell users to mount linprocfs.
  - Remove reference to special FreeBSD license.  The official license is no
    longer restricted to officially supported operating systems.
  - Create www/flashplayer which runs nspluginwrapper on installation.

  PR:		215345

Changes:
  head/MOVED
  head/www/Makefile
  head/www/flashplayer/
  head/www/flashplayer/Makefile
  head/www/flashplayer/pkg-descr
  head/www/linux-c6-flashplugin24/
  head/www/linux-c7-flashplugin24/
  head/www/linux-flashplayer/
  head/www/linux-flashplayer/Makefile
  head/www/linux-flashplayer/distinfo
  head/www/linux-flashplayer/pkg-descr
  head/www/linux-flashplayer/pkg-message
Comment 17 Tijl Coosemans freebsd_committer 2016-12-18 18:01:16 UTC
(In reply to Chen Xie from comment #15)
In Firefox->Tools->Add-ons->Plugins is the version of the flash plugin 24 or still 11?
What is the output of "find /compat/linux/usr /usr/local/lib/browser_plugins -name '*flash*'"?
Comment 18 Chen Xie 2016-12-19 01:28:04 UTC
(In reply to Tijl Coosemans from comment #17)

It shows "Shockwave Flash 24.0 r0" in about:addons.
output:
/usr/local/lib/browser_plugins/symlinks/linux-opera/libflashplayer.so
/usr/local/lib/browser_plugins/symlinks/linux-seamonkey/libflashplayer.so
/usr/local/lib/browser_plugins/symlinks/linux-opera-devel/libflashplayer.so
/usr/local/lib/browser_plugins/symlinks/linux-firefox/libflashplayer.so
/usr/local/lib/browser_plugins/linux-c6-flashplugin
/usr/local/lib/browser_plugins/linux-c6-flashplugin/libflashplayer.so
Comment 19 Chen Xie 2016-12-19 02:09:12 UTC
I deinstall linux-c6-flashplugin24 nspluginwrapper, then clean ~/.mozilla/plugins and update to the new port www/flashplayer. The problem is still there.

the output of "find /compat/linux/usr /usr/local/lib/browser_plugins -name '*flash*'":
/usr/local/lib/browser_plugins/npwrapper.libflashplayer.so
/usr/local/lib/browser_plugins/linux-flashplayer
/usr/local/lib/browser_plugins/linux-flashplayer/libflashplayer.so
/usr/local/lib/browser_plugins/symlinks/linux-firefox/libflashplayer.so
/usr/local/lib/browser_plugins/symlinks/linux-opera-devel/libflashplayer.so
/usr/local/lib/browser_plugins/symlinks/linux-seamonkey/libflashplayer.so
/usr/local/lib/browser_plugins/symlinks/linux-opera/libflashplayer.so
Comment 20 Chen Xie 2016-12-19 02:26:58 UTC
the problem of nvidia-driver ?

output of "/compat/linux/bin/sh ldd /usr/local/lib/browser_plugins/linux-flashplayer/libflashplayer.so":
        linux32_vdso.so.1 =>  (0xffffe000)
        libGL.so.1 => /usr/lib/libGL.so.1 (0x21025000)
        libdl.so.2 => /lib/libdl.so.2 (0x21139000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x2113e000)
        librt.so.1 => /lib/librt.so.1 (0x21159000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x22306000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0x21163000)
        libnss3.so => /usr/lib/libnss3.so (0x22440000)
        libsmime3.so => /usr/lib/libsmime3.so (0x211bf000)
        libssl3.so => /usr/lib/libssl3.so (0x2257e000)
        libnspr4.so => /lib/libnspr4.so (0x225c0000)
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x22600000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x22aa9000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x22b64000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x22b84000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x22bcd000)
        libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x22c02000)
        libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x22c4f000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x22d6c000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x22e05000)
        libm.so.6 => /lib/libm.so.6 (0x22ef0000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x22f1a000)
        libc.so.6 => /lib/libc.so.6 (0x22f38000)
        libnvidia-tls.so.367.44 => /usr/lib/libnvidia-tls.so.367.44 (0x211ed000)
        libnvidia-glcore.so.367.44 => /usr/lib/libnvidia-glcore.so.367.44 (0x23200000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x230d0000)
        /lib/ld-linux.so.2 (0x01001000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x230e2000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0x211f2000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0x23104000)
        libnssutil3.so => /usr/lib/libnssutil3.so (0x2311e000)
        libplc4.so => /lib/libplc4.so (0x23144000)
        libplds4.so => /lib/libplds4.so (0x211fb000)
        libz.so.1 => /lib/libz.so.1 (0x2314a000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x2315e000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x2316a000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x2316f000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0x25556000)
        libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0x255d6000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x2318e000)
        libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x231b8000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0x231bc000)
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x231c5000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0x231c8000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x231d7000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x231e2000)
        libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x231ec000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x231ef000)
        libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x231f2000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0x256fa000)
        libexpat.so.1 => /lib/libexpat.so.1 (0x25722000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x231f8000)
        libuuid.so.1 => /lib/libuuid.so.1 (0x231fb000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x2574a000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x257f6000)
        libselinux.so.1 => /lib/libselinux.so.1 (0x25810000)
Comment 21 Chris 2016-12-19 03:03:03 UTC
(In reply to Chen Xie from comment #20)

I just want to report that I have the same problem as Chen Xie and I'm also running an nvidia driver.

linprocfs is mounted but the POST-INSTALL script of flashplayer-24.0 fails.

[31/31] Installing flashplayer-24.0...
nspluginwrapper: no appropriate viewer found for /usr/local/lib/browser_plugins/linux-flashplayer/libflashplayer.so
pkg: POST-INSTALL script failed

Running 'nspluginwrapper -v -a -i' dumps a core file and no plugin is installed in ~./mozilla/plugins
Comment 22 Tijl Coosemans freebsd_committer 2016-12-19 14:13:38 UTC
(In reply to Chen Xie from comment #20)
Can you install graphics/linux-c6-glx-utils and post the output of /compat/linux/usr/bin/glxinfo?  Also, does /compat/linux/usr/bin/glxgears work?
Comment 23 Tijl Coosemans freebsd_committer 2016-12-19 14:15:47 UTC
(In reply to Chris M from comment #21)
Please post the output of "/compat/linux/bin/sh ldd /usr/local/lib/browser_plugins/linux-flashplayer/libflashplayer.so".
Comment 24 Chris 2016-12-19 16:10:10 UTC
(In reply to Tijl Coosemans from comment #23)
As requested:

ldd: warning: you do not have execution permission for `/usr/local/lib/browser_plugins/linux-flashplayer/libflashplayer.so'
	linux32_vdso.so.1 =>  (0xffffe000)
	libGL.so.1 => /usr/lib/libGL.so.1 (0x21025000)
	libdl.so.2 => /lib/libdl.so.2 (0x2113c000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x21141000)
	librt.so.1 => /lib/librt.so.1 (0x2115c000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x22306000)
	libXt.so.6 => /usr/lib/libXt.so.6 (0x21166000)
	libnss3.so => /usr/lib/libnss3.so (0x22440000)
	libsmime3.so => /usr/lib/libsmime3.so (0x211c2000)
	libssl3.so => /usr/lib/libssl3.so (0x2257e000)
	libnspr4.so => /lib/libnspr4.so (0x225c0000)
	libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x22600000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x22aa9000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x22b64000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x22b84000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x22bcd000)
	libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x22c02000)
	libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x22c4f000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x22d6c000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x22e05000)
	libm.so.6 => /lib/libm.so.6 (0x22ef0000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x22f1a000)
	libc.so.6 => /lib/libc.so.6 (0x22f38000)
	libnvidia-tls.so.340.96 => /usr/lib/libnvidia-tls.so.340.96 (0x211f0000)
	libnvidia-glcore.so.340.96 => /usr/lib/libnvidia-glcore.so.340.96 (0x23200000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x230d0000)
	/lib/ld-linux.so.2 (0x01001000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x230e2000)
	libSM.so.6 => /usr/lib/libSM.so.6 (0x211f5000)
	libICE.so.6 => /usr/lib/libICE.so.6 (0x23104000)
	libnssutil3.so => /usr/lib/libnssutil3.so (0x2311e000)
	libplc4.so => /lib/libplc4.so (0x23144000)
	libplds4.so => /lib/libplds4.so (0x2314a000)
	libz.so.1 => /lib/libz.so.1 (0x2314f000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x23163000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x2316f000)
	libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x23174000)
	libcairo.so.2 => /usr/lib/libcairo.so.2 (0x25794000)
	libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0x25814000)
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x23193000)
	libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x231bd000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0x231c1000)
	libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x231ca000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0x231cd000)
	libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x231dc000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x231e6000)
	libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x231f0000)
	libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x231f3000)
	libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x231f6000)
	libpng12.so.0 => /usr/lib/libpng12.so.0 (0x25938000)
	libexpat.so.1 => /lib/libexpat.so.1 (0x25960000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x231fb000)
	libuuid.so.1 => /lib/libuuid.so.1 (0x25988000)
	libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x2598d000)
	libresolv.so.2 => /lib/libresolv.so.2 (0x25a38000)
	libselinux.so.1 => /lib/libselinux.so.1 (0x25a52000)
Comment 25 Tijl Coosemans freebsd_committer 2016-12-19 16:47:23 UTC
Does this command print anything?

/usr/local/lib/nspluginwrapper/i386/linux/npviewer -i -p /usr/local/lib/browser_plugins/linux-flashplayer/libflashplayer.so
Comment 26 Chris 2016-12-19 16:59:04 UTC
(In reply to Tijl Coosemans from comment #25)

The command prints nothing. It just core dump immediately.
Comment 27 Tijl Coosemans freebsd_committer 2016-12-19 17:29:22 UTC
(In reply to Chris M from comment #26)
Can you install graphics/linux-c6-glx-utils and post the output of "/compat/linux/usr/bin/glxinfo | grep vendor"?  Also, does /compat/linux/usr/bin/glxgears work?
Comment 28 Chris 2016-12-19 18:14:33 UTC
(In reply to Tijl Coosemans from comment #27)

Neither of the glx commands work (I'm using linux-c6). So it looks that this is an issue with linux GL + Nvidia and not the linux flashplayer.

/compat/linux/usr/bin/glxgears 
libGL: Unable to initialize thread local storage - aborting
Abandon(core dumped)

/compat/linux/usr/bin/glxinfo
libGL: Unable to initialize thread local storage - aborting
Abandon(core dumped)


FYI, I have found an alternative that works for me (emulators/pipelight). So this is no longer an issue for me.
Comment 29 Tijl Coosemans freebsd_committer 2016-12-19 19:05:16 UTC
(In reply to Chris M from comment #28)
Ok, but I'd still like to get to the bottom of this if you don't mind :)
What is the output of "sysctl comat"?
Comment 30 Tijl Coosemans freebsd_committer 2016-12-19 19:06:58 UTC
That should be "sysctl compat".
Comment 31 Chris 2016-12-19 19:14:19 UTC
(In reply to Tijl Coosemans from comment #30)

$ sysctl compat
compat.linux32.maxvmem: 0
compat.linux32.maxssiz: 67108864
compat.linux32.maxdsiz: 536870912
compat.linux.oss_version: 198144
compat.linux.osrelease: 2.6.32
compat.linux.osname: Linux
compat.ia32.maxvmem: 0
compat.ia32.maxssiz: 67108864
compat.ia32.maxdsiz: 536870912
Comment 32 Tijl Coosemans freebsd_committer 2016-12-19 19:39:29 UTC
Can you attach /var/log/Xorg.0.log?
Comment 33 Chris 2016-12-19 19:52:49 UTC
Created attachment 178117 [details]
Xorg.0.log

/var/log/Xorg.0.log as requested
Comment 34 commit-hook freebsd_committer 2016-12-19 21:14:05 UTC
A commit references this bug:

Author: tijl
Date: Mon Dec 19 21:13:03 UTC 2016
New revision: 428960
URL: https://svnweb.freebsd.org/changeset/ports/428960

Log:
  Add build dependency on linux_base so the build process can run tls_test.
  This affects which copy of Linux libnvidia-tls gets installed.
  Also add a run dependency on Linux Xorg libraries needed by some of the
  installed libraries.

  PR:		215345

Changes:
  head/x11/nvidia-driver/Makefile
  head/x11/nvidia-driver-304/Makefile
  head/x11/nvidia-driver-340/Makefile
Comment 35 Tijl Coosemans freebsd_committer 2016-12-19 21:21:50 UTC
I believe the commit above will fix the problem with nvidia-driver.  Please give it a try and let me know.
Comment 36 Chris 2016-12-19 21:50:12 UTC
(In reply to Tijl Coosemans from comment #35)

I can confirm that the latest commit fixed it. 
linux-flashplayer is now working on my system.

Thank you Tijl!
Comment 37 Chen Xie 2016-12-20 10:21:21 UTC
Created attachment 178140 [details]
Xorg.0.log
Comment 38 Chen Xie 2016-12-20 10:22:25 UTC
Unfortunately, flash does not work in my PC after I upgrade the lastest ports. When flash is running in firefox, it is a black image and npviewer.bin.core appears.

/usr/local/lib/nspluginwrapper/i386/linux/npviewer -i -p /usr/local/lib/browser_plugins/linux-flashplayer/libflashplayer.so:

PLUGIN_NAME 15
Shockwave Flash
PLUGIN_DESC 23
Shockwave Flash 24.0 r0
PLUGIN_MIME 98
application/x-shockwave-flash:swf:Shockwave Flash;application/futuresplash:spl:FutureSplash Player

/compat/linux/bin/sh ldd /usr/local/lib/browser_plugins/linux-flashplayer/libflashplayer.so:

ldd: warning: you do not have execution permission for `/usr/local/lib/browser_plugins/linux-flashplayer/libflashplayer
.so'
        linux32_vdso.so.1 =>  (0xffffe000)
        libGL.so.1 => /usr/lib/libGL.so.1 (0x21025000)
        libdl.so.2 => /lib/libdl.so.2 (0x21139000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x2113e000)
        librt.so.1 => /lib/librt.so.1 (0x21159000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x22306000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0x21163000)
        libnss3.so => /usr/lib/libnss3.so (0x22440000)
        libsmime3.so => /usr/lib/libsmime3.so (0x211bf000)
        libssl3.so => /usr/lib/libssl3.so (0x2257e000)
        libnspr4.so => /lib/libnspr4.so (0x225c0000)
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x22600000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x22aa9000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x22b64000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x22b84000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x22bcd000)
        libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x22c02000)
        libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x22c4f000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x22d6c000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x22e05000)
        libm.so.6 => /lib/libm.so.6 (0x22ef0000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x22f1a000)
        libc.so.6 => /lib/libc.so.6 (0x22f38000)
        libnvidia-tls.so.367.44 => /usr/lib/libnvidia-tls.so.367.44 (0x211ed000)
        libnvidia-glcore.so.367.44 => /usr/lib/libnvidia-glcore.so.367.44 (0x23200000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x230d0000)
        /lib/ld-linux.so.2 (0x01001000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x230e2000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0x211f2000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0x23104000)
        libnssutil3.so => /usr/lib/libnssutil3.so (0x2311e000)
        libplc4.so => /lib/libplc4.so (0x23144000)
        libplds4.so => /lib/libplds4.so (0x211fb000)
        libz.so.1 => /lib/libz.so.1 (0x2314a000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x2315e000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x2316a000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x2316f000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0x25556000)
        libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0x255d6000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x2318e000)
        libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x231b8000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0x231bc000)
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x231c5000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0x231c8000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x231d7000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x231e2000)
        libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x231ec000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x231ef000)
        libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x231f2000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0x256fa000)
        libexpat.so.1 => /lib/libexpat.so.1 (0x25722000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x231f8000)
        libuuid.so.1 => /lib/libuuid.so.1 (0x231fb000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x2574a000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x257f6000)
        libselinux.so.1 => /lib/libselinux.so.1 (0x25810000)

/compat/linux/usr/bin/glxgears works:

Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
303 frames in 5.0 seconds = 60.556 FPS
301 frames in 5.0 seconds = 60.005 FPS
301 frames in 5.0 seconds = 60.005 FPS
301 frames in 5.0 seconds = 60.004 FPS
301 frames in 5.0 seconds = 60.005 FPS
301 frames in 5.0 seconds = 60.003 FPS
301 frames in 5.0 seconds = 60.002 FPS
300 frames in 5.0 seconds = 59.969 FPS
300 frames in 5.0 seconds = 59.842 FPS
301 frames in 5.0 seconds = 60.005 FPS
301 frames in 5.0 seconds = 60.005 FPS
301 frames in 5.0 seconds = 60.004 FPS
301 frames in 5.0 seconds = 60.004 FPS
301 frames in 5.0 seconds = 60.004 FPS
301 frames in 5.0 seconds = 60.004 FPS

/compat/linux/usr/bin/glxinfo | grep vendor:

server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

sysctl compat:

compat.linux32.maxvmem: 0
compat.linux32.maxssiz: 67108864
compat.linux32.maxdsiz: 536870912
compat.linux.oss_version: 198144
compat.linux.osrelease: 2.6.32
compat.linux.osname: Linux
compat.ia32.maxvmem: 0
compat.ia32.maxssiz: 67108864
compat.ia32.maxdsiz: 536870912
Comment 39 Chen Xie 2016-12-20 10:28:28 UTC
Created attachment 178141 [details]
glxinfo output
Comment 40 Tijl Coosemans freebsd_committer 2016-12-20 13:20:35 UTC
(In reply to Chen Xie from comment #39)
Can you attach the core dump?  I probably won't be able to extract much from it, but you never know.
Comment 41 Tijl Coosemans freebsd_committer 2016-12-27 15:32:51 UTC
So the coredump contained an access to address 0xfffff000 in libflashplayer.so, but the code is too obscure for me to figure out why without spending considerable time.  Somebody reported a problem with astro/google-earth in bug 215500.  Is that something you can reproduce?

If your graphics card is supported by the older x11/nvidia-driver-340 maybe you can use that for now.
Comment 42 Chen Xie 2016-12-28 09:47:37 UTC
(In reply to Tijl Coosemans from comment #41)

When I was using nvidia-driver-367.44, goolge-earth crashed immediately just like bug 215500. When I was using nvidia-driver-340, I rotated the globe and zoomed in, then google-earth crashed.

But flashplayer also crashed under nvidia-driver-340. Maybe it is an individual problem, thanks Tijl.
Comment 43 Tijl Coosemans freebsd_committer 2016-12-28 10:51:28 UTC
(In reply to Chen Xie from comment #42)
One more thing you could try is to mount tmpfs on /compat/linux/dev/shm as explained in the linux_base-c6 pkg-message, which you can display using "pkg info -D linux_base-c6".
Comment 44 Chen Xie 2016-12-28 14:09:09 UTC
(In reply to Tijl Coosemans from comment #43)

Now tmpfs is mounted as it is mentioned in the pkg-message of linux_base-c6. Some web pages tell me that flashplugin is not installed, others' flashplugin crashes. 

Other people do not report this flashplugin24 issue. So alone with this.
Comment 45 Tijl Coosemans freebsd_committer 2016-12-28 18:50:40 UTC
(In reply to Chen Xie from comment #44)
Do you set any tunables in /etc/sysctl.conf or /boot/loader.conf?
Something else you could try is to run 'firefox --ProfileManager' and create a new clean profile.
Comment 46 Chen Xie 2016-12-29 08:02:20 UTC
(In reply to Tijl Coosemans from comment #45)

/etc/sysctl.conf:
security.bsd.see_other_uids=0
security.bsd.see_other_gids=0
security.bsd.unprivileged_read_msgbuf=0
security.bsd.unprivileged_proc_debug=0
security.bsd.stack_guard_page=1

/boot/loader.conf:
geli_ada0p5_keyfile0_load="YES"
geli_ada0p5_keyfile0_type="ada0p5:geli_keyfile0"
geli_ada0p5_keyfile0_name="/boot/encryption.key"
geli_ada1p5_keyfile0_load="YES"
geli_ada1p5_keyfile0_type="ada1p5:geli_keyfile0"
geli_ada1p5_keyfile0_name="/boot/encryption.key"
aesni_load="YES"
geom_eli_load="YES"
geom_mirror_load="YES"
vfs.root.mountfrom="zfs:zroot/ROOT/default"
kern.geom.label.disk_ident.enable="0"
kern.geom.label.gptid.enable="0"
zpool_cache_load="YES"
zpool_cache_type="/boot/zfs/zpool.cache"
zpool_cache_name="/boot/zfs/zpool.cache"
geom_eli_passphrase_prompt="YES"
zfs_load="YES"
verbose_loading="YES"
boot_verbose="-v"
autoboot_delay="3"
vfs.zfs.arc_max="13G"
vboxdrv_load="YES"
fdescfs_load="YES"
linprocfs_load="YES"
tmpfs_load="YES"

It becomes better. After reinstalling firefox and deleting ~/.mozilla, some website flash work, others still crash.
Comment 47 Tijl Coosemans freebsd_committer 2016-12-29 12:54:41 UTC
(In reply to Chen Xie from comment #46)
None of those settings should be a problem.  Can you give an example of a website that fails?
Comment 48 Chen Xie 2016-12-29 15:01:27 UTC
(In reply to Tijl Coosemans from comment #47)

All flash at http://www.youku.com/ crashed. Some flash at http://v.ifeng.com/ worked. If you can run flashplayer at the former, I believe that it is exactly an individual issue.
Comment 49 Tijl Coosemans freebsd_committer 2016-12-29 16:38:52 UTC
(In reply to Chen Xie from comment #48)
I don't use nvidia-driver, but playing videos on youku worked for me.  ifeng was very slow to load.  Eventually it did load flash but it never got to the point of playing video.  Just a little animation indicating it was still loading.  The flash plugin never crashed though.  Did you change any of the options in www/firefox?  What is the output of "make -C /usr/ports/www/firefox showconfig"?
Comment 50 Chen Xie 2016-12-30 06:03:57 UTC
(In reply to Tijl Coosemans from comment #49)

I use the default configuration.

===> The following configuration options are available for firefox-50.1.0_4,1:
     BUNDLED_CAIRO=on: Use bundled fork of cairo-1.9.5
     CANBERRA=off: Sound theme alerts
     DBUS=on: D-Bus IPC system support
     DEBUG=off: Build with debugging support
     DTRACE=on: Build with DTrace probes
     FFMPEG=on: FFmpeg support (WMA, AIFF, AC3, APE...)
     GCONF=off: GConf configuration backend support
     GNOMEUI=off: libgnomeui support module
     INTEGER_SAMPLES=off: Integer audio sample format
     LIBPROXY=off: Proxy support via libproxy
     OPTIMIZED_CFLAGS=on: Use extra compiler optimizations
     PGO=off: Use Profile-Guided Optimization
     PROFILE=off: Build with profiling support
     RUST=on: Build with components written in Rust language
     TEST=off: Build and/or run tests
====> Options available for the multi AUDIO: you have to choose at least one of them
     ALSA=on: ALSA audio architecture support
     PULSEAUDIO=on: PulseAudio sound server support
====> Options available for the single TOOLKIT: you have to select exactly one of them
     GTK2=off: GTK+ 2 GUI toolkit support
     GTK3=on: GTK+ 3 GUI toolkit support
===> Use 'make config' to modify these settings
Comment 51 Tijl Coosemans freebsd_committer 2017-01-09 16:13:07 UTC
In /usr/local/lib/nspluginwrapper/i386/linux/npviewer can you replace "ulimit -s 32768" with "ulimit -s 8192"?
Comment 52 Chen Xie 2017-01-10 01:47:12 UTC
(In reply to Tijl Coosemans from comment #51)

Vector smash protection is enabled.
*** NSPlugin Wrapper *** ERROR: NPP_WriteReady() invoke: Broken pipe
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2705):invoke_NPP_Write: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2550):invoke_NPP_DestroyStream: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x81554b6e0 is no longer valid!
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2219):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/wrkdirs/usr/ports/www/nspluginwrapper/work/nspluginwrapper-1.4.4/src/npw-wrapper.c:2219):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))

Shall I compile a debug firefox to reproduce the core file?

And FreeBSD mail server rejected the email including core file because message size exceeds fixed limit.
Comment 53 Chen Xie 2017-01-13 02:41:47 UTC
Thanks Tijl Coosemans. After configuring security.bsd.unprivileged_proc_debug=1, flash player on firefox is all right. The two addons uBlock Origin and HTTPS Everywhere also influence flash t
o operate on some websites.