Bug 215366 - emulators/open-vm-tools: hgfs component doesn't compile (undefined behavior with #define; clang 3.9.0+)
Summary: emulators/open-vm-tools: hgfs component doesn't compile (undefined behavior w...
Status: Closed DUPLICATE of bug 212426
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-17 23:18 UTC by Enji Cooper
Modified: 2016-12-17 23:20 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (swills)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Enji Cooper freebsd_committer 2016-12-17 23:18:37 UTC
--- hgfsServerLinux.lo ---
hgfsServerLinux.c:1989:8: error: macro expansion producing 'defined' has undefined behavior [-Werror,-Wexpansion-to-defined]
#   if __IS_FREEBSD_VER__(500043)
       ^
/home/ngie/nfs/git/freebsd-ports~/emulators/open-vm-tools/work/open-vm-tools-9.4.0-1280544/lib/include/vm_basic_defs.h:85:34: note: expanded from macro '__IS_FREEBSD_VER__'
#define __IS_FREEBSD_VER__(ver) (__IS_FREEBSD__ && __FreeBSD_version >= (ver))
                                 ^
/home/ngie/nfs/git/freebsd-ports~/emulators/open-vm-tools/work/open-vm-tools-9.4.0-1280544/lib/include/vm_basic_defs.h:84:26: note: expanded from macro '__IS_FREEBSD__'
#define __IS_FREEBSD__ (!defined(VMKERNEL) && defined(__FreeBSD__))
                         ^
hgfsServerLinux.c:1989:8: error: macro expansion producing 'defined' has undefined behavior [-Werror,-Wexpansion-to-defined]
/home/ngie/nfs/git/freebsd-ports~/emulators/open-vm-tools/work/open-vm-tools-9.4.0-1280544/lib/include/vm_basic_defs.h:85:34: note: expanded from macro '__IS_FREEBSD_VER__'
#define __IS_FREEBSD_VER__(ver) (__IS_FREEBSD__ && __FreeBSD_version >= (ver))
                                 ^
/home/ngie/nfs/git/freebsd-ports~/emulators/open-vm-tools/work/open-vm-tools-9.4.0-1280544/lib/include/vm_basic_defs.h:84:47: note: expanded from macro '__IS_FREEBSD__'
#define __IS_FREEBSD__ (!defined(VMKERNEL) && defined(__FreeBSD__))
                                              ^
2 errors generated.
*** [hgfsServerLinux.lo] Error code 1

make[4]: stopped in /home/ngie/nfs/git/freebsd-ports~/emulators/open-vm-tools/work/open-vm-tools-9.4.0-1280544/lib/hgfsServer

$ uname -a
FreeBSD  12.0-CURRENT FreeBSD 12.0-CURRENT #0 r310128+9d52c8cacb7d(bsnmp-improved-ipv6-support): Sat Dec 17 14:23:33 PST 2016     ngie@fbsd12:/usr/obj/usr/src/git/sys/GENERIC-NODEBUG  amd64
Comment 1 Enji Cooper freebsd_committer 2016-12-17 23:20:46 UTC
Dupe of bug 212426 (my ports tree has issues right now.. I'm working on fixing them).

*** This bug has been marked as a duplicate of bug 212426 ***