Bug 215517 - sysutils/polkit: use clang on armv6
Summary: sysutils/polkit: use clang on armv6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Many People
Assignee: freebsd-gnome mailing list
URL:
Keywords:
Depends on: 215516
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-23 15:18 UTC by mikael.urankar
Modified: 2017-05-10 21:38 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
use clang (566 bytes, patch)
2016-12-23 15:18 UTC, mikael.urankar
no flags Details | Diff
build log (175.35 KB, text/plain)
2016-12-23 15:18 UTC, mikael.urankar
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mikael.urankar 2016-12-23 15:18:22 UTC
Created attachment 178226 [details]
use clang

Hi,

clang can build polkit with bug #215516

Thanks in advance
Comment 1 mikael.urankar 2016-12-23 15:18:52 UTC
Created attachment 178227 [details]
build log
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2017-02-03 13:06:22 UTC
polkit builds on armv6 as of 20170124.  Is this PR still relevant?
Comment 3 mikael.urankar 2017-02-03 13:26:21 UTC
Yes the pr is still relevant.
Comment 4 commit-hook freebsd_committer 2017-05-10 21:38:14 UTC
A commit references this bug:

Author: kwm
Date: Wed May 10 21:37:57 UTC 2017
New revision: 440593
URL: https://svnweb.freebsd.org/changeset/ports/440593

Log:
  Drop the use of USE_GCC on arm.

  PR:		215517
  Submitted by:	mikael.urankar@gmail.com

Changes:
  head/sysutils/polkit/Makefile