Bug 215610 - net/kea: pkg-plist contains duplicate entries
Summary: net/kea: pkg-plist contains duplicate entries
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Cy Schubert
URL:
Keywords: needs-patch, regression
Depends on:
Blocks:
 
Reported: 2016-12-27 12:46 UTC by Jan Beich
Modified: 2016-12-27 17:21 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (hrs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2016-12-27 12:46:49 UTC
Added by ports r426825 by cy@ but not sure why. It breaks "poudriere bulk -t":

=======================<phase: package        >============================
===>  Building package for kea-1.1.0_3
pkg-static: duplicate file listing: /usr/local/include/kea/cc/data.h, fatal (developer mode)
pkg-static: duplicate file listing: /usr/local/share/kea/scripts/cql/dhcpdb_create.cql, fatal (developer mode)
pkg-static: duplicate file listing: /usr/local/share/kea/scripts/cql/dhcpdb_drop.cql, fatal (developer mode)
pkg-static: duplicate file listing: /usr/local/share/kea/scripts/mysql/dhcpdb_drop.mysql, fatal (developer mode)
pkg-static: duplicate file listing: /usr/local/share/kea/scripts/mysql/upgrade_4.1_to_5.0.sh, fatal (developer mode)
pkg-static: duplicate file listing: /usr/local/share/kea/scripts/pgsql/dhcpdb_drop.pgsql, fatal (developer mode)
pkg-static: duplicate file listing: /usr/local/share/kea/scripts/pgsql/upgrade_2.0_to_3.0.sh, fatal (developer mode)
*** Error code 1

full build log: http://sprunge.us/adBU
Comment 1 Cy Schubert freebsd_committer 2016-12-27 17:15:17 UTC
I'm not sure how that crept in. I should have run svn st first. I'll fix it.
Comment 2 commit-hook freebsd_committer 2016-12-27 17:20:56 UTC
A commit references this bug:

Author: cy
Date: Tue Dec 27 17:20:21 UTC 2016
New revision: 429631
URL: https://svnweb.freebsd.org/changeset/ports/429631

Log:
  Fix build due to breakage from r426825, targeting net/ntp*. The patch
  to net/kea/pkg-plist was never intended in r426825. r426825 was for
  net/ntp* only.

  PR:		215610
  Reported by:	jbeich
  Pointy hat to:	cy (me)

Changes:
  head/net/kea/pkg-plist
Comment 3 Cy Schubert freebsd_committer 2016-12-27 17:21:51 UTC
Sorry for the inconvenience.