Bug 215617 - graphics/urt save from deprecation
Summary: graphics/urt save from deprecation
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rene Ladan
URL:
Keywords:
Depends on:
Blocks: 211921
  Show dependency treegraph
 
Reported: 2016-12-27 18:30 UTC by Pedro F. Giffuni
Modified: 2017-04-28 11:18 UTC (History)
2 users (show)

See Also:


Attachments
Update urt to the version carried by funet (96.75 KB, patch)
2016-12-27 18:30 UTC, Pedro F. Giffuni
no flags Details | Diff
Update and add the missing headers (96.17 KB, patch)
2017-03-12 23:14 UTC, Pedro F. Giffuni
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro F. Giffuni freebsd_committer 2016-12-27 18:30:47 UTC
Created attachment 178329 [details]
Update urt to the version carried by funet

Use funet.fi: we were taking a patch from there so we can go ahead and take the patched tarball instead.

We do lose:
- sample images.
- man pages.
- Some headers.

graphics/rayshade builds.
I haven't tested cad/brlcad yet but that port carries it's own urt if we need to.

Other cleanups:
- Add LICENSE.
- Use make makepatch: remove an hpux patch since we don't care about it.
Comment 1 Rene Ladan freebsd_committer 2017-03-12 14:44:57 UTC
The patch looks good up to now (12-amd64 and 10-i386 tested). Pedro, would you like to maintain the port?
Comment 2 Rene Ladan freebsd_committer 2017-03-12 15:19:32 UTC
I've tried to build graphics/rayshade in poudriere, and it fails to build with the new graphics/urt:

image.c:27:10: fatal error: 'rle.h' file not found
#include "rle.h"
         ^~~~~~~

It looks like graphics/rayshade mostly had framework updates in the last years, but no actual version updates.
Comment 3 Pedro F. Giffuni freebsd_committer 2017-03-12 15:59:53 UTC
(In reply to Rene Ladan from comment #1)

I would prefer not to maintain URT at this time. I am just hoping to save rayshade and keep kicking brlcad when I find time :-/.

Thanks for looking at it and reporting the rayshade issue.
Comment 4 Pedro F. Giffuni freebsd_committer 2017-03-12 16:49:42 UTC
(In reply to Rene Ladan from comment #2)
I can't reproduce the rayshade failure:

:/usr/ports/graphics/rayshade # make BATCH=yes install
===>  Installing for rayshade-4.0.6_7
===>  Checking if rayshade already installed
===>   Registering installation for rayshade-4.0.6_7
Installing rayshade-4.0.6_7...
____

The configuration does produce some "fatal" errors, but they seem to be of no concern.
Comment 5 Rene Ladan freebsd_committer 2017-03-12 20:10:31 UTC
Are you sure you have the new graphics/urt installed, so that an old rle.h is not lingering around somewhere? poudriere uses a clean environment and does complain.
Comment 6 Pedro F. Giffuni freebsd_committer 2017-03-12 20:43:57 UTC
(In reply to Rene Ladan from comment #5)
Ooops ...

I had to manually remove some old remaining files and now I can reproduce it.
I'll be back.
Comment 7 Pedro F. Giffuni freebsd_committer 2017-03-12 23:14:31 UTC
Created attachment 180758 [details]
Update and add the missing headers

Fix by post-installing all the headers.
Comment 8 Chris Hutchinson 2017-03-22 18:45:35 UTC
Heh. Wish I'd seen this pr earlier...

Please see pr 218016

I've done a boat load of work on this port, and
I'll actually maintain it. :-)

Thanks.

--Chris
Comment 9 Pedro F. Giffuni freebsd_committer 2017-03-22 19:15:23 UTC
(In reply to Chris Hutchinson from comment #8)

I am fine with you taking over .. Thanks!
Comment 10 Chris Hutchinson 2017-03-22 19:38:41 UTC
(In reply to Pedro F. Giffuni from comment #9)
> (In reply to Chris Hutchinson from comment #8)
> 
> I am fine with you taking over .. Thanks!

Heh. I'm not surprised. As you've seen; this port
isn't a lot of fun. :-)

All the best to you, Pedro, and thanks!

--Chris
Comment 11 Pedro F. Giffuni freebsd_committer 2017-03-22 20:34:03 UTC
(In reply to Chris Hutchinson from comment #10)
Oh, it is a fun port .. it just requires time which is scarce these days ;).
Comment 12 Chris Hutchinson 2017-03-23 01:12:24 UTC
(In reply to Pedro F. Giffuni from comment #11)
> (In reply to Chris Hutchinson from comment #10)
> Oh, it is a fun port .. it just requires time which is scarce these days ;).

You said it, brother! ;-)

--Chris
Comment 13 Rene Ladan freebsd_committer 2017-04-28 11:18:45 UTC
Superseded by PR 218016