Bug 215676 - [PATCH] editors/vim: update auto-configure patch for current Python3 releases
Summary: [PATCH] editors/vim: update auto-configure patch for current Python3 releases
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Adam Weinberger
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-12-30 21:34 UTC by rsmith
Modified: 2016-12-31 14:55 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (adamw)


Attachments
Patch for the vim port to update python support. (547 bytes, patch)
2016-12-30 21:34 UTC, rsmith
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rsmith 2016-12-30 21:34:06 UTC
Created attachment 178408 [details]
Patch for the vim port to update python support.

The 'patch-src-auto-configure' patch tests for python 3.2 up to and including 3.5. This means that building vim with python version 3.6 fails to include the python feature.

The attached patch updates that to python3.3 up to and including 3.6.
Comment 1 Adam Weinberger freebsd_committer 2016-12-30 21:38:41 UTC
Thanks, Roland. I'll put that into tomorrow's commit.
Comment 2 commit-hook freebsd_committer 2016-12-31 14:53:36 UTC
A commit references this bug:

Author: adamw
Date: Sat Dec 31 14:52:35 UTC 2016
New revision: 430125
URL: https://svnweb.freebsd.org/changeset/ports/430125

Log:
  Remove the check for python 3.2, and add a check for python 3.6. Without
  this, users with DEFAULT_VERSIONS+=python=3.6 were getting vim without
  python3 support. PORTREVISION bump for this, because py3.6 users need
  a rebuilt vim.

  PR:		215676
  Submitted by:	rsmith xs4all nl

Changes:
  head/editors/vim/Makefile
  head/editors/vim/files/patch-src-auto-configure
Comment 3 Adam Weinberger freebsd_committer 2016-12-31 14:55:01 UTC
Committed. Thanks for this, Roland. I was bit by this and didn't even realize it!