Bug 215767 - devel/babeltrace: update to 1.5.0
Summary: devel/babeltrace: update to 1.5.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Olivier Cochard
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-04 16:18 UTC by luca.pizzamiglio
Modified: 2017-01-12 14:31 UTC (History)
1 user (show)

See Also:


Attachments
The updating patch (2.87 KB, patch)
2017-01-04 16:18 UTC, luca.pizzamiglio
luca.pizzamiglio: maintainer-approval+
Details | Diff
poudriere build on FreeBSD 10.3 i386 (209.34 KB, text/x-log)
2017-01-04 16:19 UTC, luca.pizzamiglio
no flags Details
poudriere build on FreeBSD 11 amd64 (242.37 KB, text/x-log)
2017-01-04 16:19 UTC, luca.pizzamiglio
no flags Details
New patch to update to 1.5.1 and removing (3.88 KB, patch)
2017-01-10 15:05 UTC, luca.pizzamiglio
luca.pizzamiglio: maintainer-approval+
Details | Diff
poudriere build on FreeBSD 11 amd64 (239.98 KB, text/x-log)
2017-01-10 15:05 UTC, luca.pizzamiglio
no flags Details
poudriere build on FreeBSD 10.3 i386 (206.55 KB, text/x-log)
2017-01-10 15:06 UTC, luca.pizzamiglio
no flags Details
Recreating the patch (2.87 KB, patch)
2017-01-12 14:02 UTC, luca.pizzamiglio
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description luca.pizzamiglio 2017-01-04 16:18:39 UTC
Created attachment 178511 [details]
The updating patch

devel/babeltrace: updating to version 1.5.0

Updating this trace library to the last version
Several fixes and improvements added.
No merge-quarterly needed.
Removing gettext direct requirements, because it's not directly needed.
gettext-runtime is needed by glib-20, but not 

portlint: OK (looks fine.)
testport: OK (poudriere: 10.3,11.0 on amd64,i386)
Comment 1 luca.pizzamiglio 2017-01-04 16:19:11 UTC
Created attachment 178512 [details]
poudriere build on FreeBSD 10.3 i386
Comment 2 luca.pizzamiglio 2017-01-04 16:19:43 UTC
Created attachment 178513 [details]
poudriere build on FreeBSD 11 amd64
Comment 3 luca.pizzamiglio 2017-01-10 15:05:17 UTC
Created attachment 178716 [details]
New patch to update to 1.5.1 and removing

devel/babeltrace: updating to version 1.5.1

Updating this trace library to the last version
Several fixes and improvements added.
No merge-quarterly needed.
Removing gettext direct requirements, because it's not directly needed.
gettext-runtime is needed by glib-20, but not by babeltrace
Removed FreeBSD 9x support and workarounds

portlint: OK (looks fine.)
testport: OK (poudriere: 10.3,11.0 on amd64,i386)
Comment 4 luca.pizzamiglio 2017-01-10 15:05:51 UTC
Created attachment 178717 [details]
poudriere build on FreeBSD 11 amd64
Comment 5 luca.pizzamiglio 2017-01-10 15:06:51 UTC
Created attachment 178718 [details]
poudriere build on FreeBSD 10.3 i386
Comment 6 luca.pizzamiglio 2017-01-12 14:02:59 UTC
Created attachment 178792 [details]
Recreating the patch

Recreating the patch
The previous one was broken by r430947
Comment 7 commit-hook freebsd_committer 2017-01-12 14:31:10 UTC
A commit references this bug:

Author: olivier
Date: Thu Jan 12 14:31:01 UTC 2017
New revision: 431272
URL: https://svnweb.freebsd.org/changeset/ports/431272

Log:
  Update to version 1.5.1

  PR:		215767
  Submitted by:	luca.pizzamiglio@gmail.com (maintainer)

Changes:
  head/devel/babeltrace/Makefile
  head/devel/babeltrace/distinfo
  head/devel/babeltrace/files/patch-include_babeltrace_compat_limits.h
  head/devel/babeltrace/pkg-plist
Comment 8 Olivier Cochard freebsd_committer 2017-01-12 14:31:49 UTC
Thanks for the update.