Bug 215768 - [exp-run] textproc/gsed: Update to version 4.7
Summary: [exp-run] textproc/gsed: Update to version 4.7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Alexey Dokuchaev
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2017-01-04 16:34 UTC by Pedro F. Giffuni
Modified: 2019-01-21 18:21 UTC (History)
5 users (show)

See Also:
danfe: maintainer-feedback-
antoine: exp-run+


Attachments
Update to version 4.3 (2.37 KB, patch)
2017-01-04 16:34 UTC, Pedro F. Giffuni
no flags Details | Diff
Update to version 4.3 (2.63 KB, patch)
2017-01-20 15:29 UTC, Pedro F. Giffuni
no flags Details | Diff
Update to version 4.4 (3.15 KB, patch)
2017-03-08 10:32 UTC, Alexey Dokuchaev
no flags Details | Diff
Update to version 4.7 (3.03 KB, patch)
2019-01-18 14:22 UTC, Alexey Dokuchaev
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro F. Giffuni freebsd_committer 2017-01-04 16:34:22 UTC
Created attachment 178514 [details]
Update to version 4.3

I noticed there was a new version of GNU sed and I was bored ...

Pet portlint (add license), and remove some unused cruft while here.
Comment 1 Xin LI freebsd_committer 2017-01-20 06:54:36 UTC
Maintainer timed out.
Comment 2 Xin LI freebsd_committer 2017-01-20 07:01:44 UTC
Please also fix the two INSTALL_DATA commands so they are not muted, as pointed out by portlint -C when you commit.
Comment 3 Pedro F. Giffuni freebsd_committer 2017-01-20 15:29:58 UTC
Created attachment 179139 [details]
Update to version 4.3

Fixed muted INSTALL_foo commands (from portlint)
Comment 4 Pedro F. Giffuni freebsd_committer 2017-01-20 15:31:27 UTC
(In reply to Xin LI from comment #2)
I am not a ports committer so I should send this back to the pool.
Comment 5 Wen Heping freebsd_committer 2017-02-01 01:38:43 UTC
I failed build on 10.3-i386, last lines of log :

depbase=`echo sed/sed_sed-utils.o | sed 's|[^/]*$|.deps/&|;s|\.[^.]*$||'` && \
cc -std=gnu11 -DHAVE_CONFIG_H -I.  -I. -I./lib -I./lib -I./sed -DLOCALEDIR=\"/usr/local/share/locale\" -DLIBICONV_PLUG -I/usr/local/include    -O2 -pipe  -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing -MT sed/sed_sed-utils.o -MD -MP -MF $depbase.Tpo -c -o sed/sed_sed-utils.o  `test -f 'sed/utils.c' || echo './'`sed/utils.c; \
if test $? = 0; then mv -f $depbase.Tpo $depbase.Po; \
  else rm -f $depbase.Tpo; false; fi
rm -f lib/libsed.a
ar cr lib/libsed.a lib/copy-acl.o lib/set-acl.o lib/acl-errno-valid.o lib/acl-internal.o lib/get-permissions.o lib/set-permissions.o lib/c-ctype.o lib/c-strcasecmp.o lib/c-strncasecmp.o lib/close-stream.o lib/closeout.o lib/dfa.o lib/localeinfo.o lib/dirname-lgpl.o lib/basename-lgpl.o lib/stripslash.o lib/exitfail.o lib/getprogname.o lib/hard-locale.o lib/localcharset.o lib/glthread/lock.o lib/malloca.o lib/progname.o lib/qcopy-acl.o lib/qset-acl.o lib/quotearg.o lib/se-context.o lib/se-selinux.o lib/tempname.o lib/glthread/threadlib.o lib/unistd.o lib/version-etc.o lib/version-etc-fsf.o lib/wctype-h.o lib/xmalloc.o lib/xalloc-die.o lib/acl_entries.o lib/canonicalize-lgpl.o lib/error.o lib/fpending.o lib/fwriting.o lib/getopt.o lib/getopt1.o lib/obstack.o lib/regex.o lib/secure_getenv.o lib/strverscmp.o
ranlib lib/libsed.a
rm -f sed/libver.a
ar cr sed/libver.a sed/version.o
ranlib sed/libver.a
cc -std=gnu11    -O2 -pipe  -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing  -fstack-protector -o sed/sed sed/sed_sed-compile.o sed/sed_sed-execute.o sed/sed_sed-mbcs.o sed/sed_sed-regexp.o sed/sed_sed-sed.o sed/sed_sed-utils.o sed/libver.a lib/libsed.a /usr/local/lib/libintl.so -Wl,-rpath -Wl,/usr/local/lib
/bin/mkdir -p doc
rm -rf doc/sed.1 doc/sed.1-t
./build-aux/help2man                                            \
    --name 'stream editor for filtering and transforming text'  \
    -p sed --include ./doc/sed.x                        \
    -o doc/sed.1-t sed/sed                                              \
  && chmod a-w doc/sed.1-t                                              \
  && mv doc/sed.1-t doc/sed.1
env: perl: No such file or directory
gmake[3]: *** [Makefile:5775: doc/sed.1] Error 127
gmake[3]: Leaving directory '/wrkdirs/usr/ports/textproc/gsed/work/sed-4.3'
gmake[2]: *** [Makefile:3024: all-recursive] Error 1
gmake[2]: Leaving directory '/wrkdirs/usr/ports/textproc/gsed/work/sed-4.3'
gmake[1]: *** [Makefile:2156: all] Error 2
gmake[1]: Leaving directory '/wrkdirs/usr/ports/textproc/gsed/work/sed-4.3'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
Comment 6 Pedro F. Giffuni freebsd_committer 2017-02-01 02:18:44 UTC
(In reply to Wen Heping from comment #5)

Ugh ... add the port maintainer to the bug report. Maybe he is familiar with the issue.
Comment 7 Alexey Dokuchaev freebsd_committer 2017-03-08 10:32:01 UTC
Created attachment 180628 [details]
Update to version 4.4

Thanks Pedro, I'll lift it up from here.  Please see updated patch (to version 4.4).  It is based on yours plus additional improvements and cleanups.

I guess an exp-run is in order now so we can be sure it does not break any consumers.
Comment 8 Antoine Brodin freebsd_committer 2017-03-08 14:50:57 UTC
- Why not use the test framework  (TEST_TARGET=check-TESTS for instance)

- Is is normal that most regression tests are now failing?  they were all succeeding with previous version
Comment 9 Antoine Brodin freebsd_committer 2017-03-08 15:19:15 UTC
(In reply to Antoine Brodin from comment #8)
Funny, tests seem to run fine with bsd make but not with gmake
Comment 10 Pedro F. Giffuni freebsd_committer 2017-03-08 15:42:41 UTC
(In reply to Alexey Dokuchaev from comment #7)

Thanks for picking it up, I really have no time for it.

I am wondering why you need an exp-run: very few ports depend on gsed, and BSD sed has become much more compatible since FreeBSD 11. Poudriere should suffice.
Comment 11 Alexey Dokuchaev freebsd_committer 2017-03-08 16:15:37 UTC
Well I'm glad that I asked for an exp-run (my quick grepping revealed more than just a few ports, so I thought it would be a good idea): Antoine already pointed out two important issues.

Regardless of whether exp-run will show any regressions, I'd like to fix those issues before the patch hits the tree (that is, employ TEST_TARGET and either switch to BSD make if that's sufficient or fix the test suite so it passes fine with GNU make).
Comment 12 Antoine Brodin freebsd_committer 2017-03-25 09:55:01 UTC
any progress on the regression tests?
Comment 13 Antoine Brodin freebsd_committer 2017-04-03 19:03:29 UTC
back to the team
Comment 14 Eitan Adler freebsd_committer freebsd_triage 2018-05-23 10:27:39 UTC
batch change of PRs untouched in 2018 marked "in progress" back to open.
Comment 15 Pedro F. Giffuni freebsd_committer 2018-05-23 14:39:29 UTC
This has taken forever an upstream is already on version 4.5.
I'll let someone else take a fresh look.
Comment 16 Alexey Dokuchaev freebsd_committer 2019-01-18 14:22:11 UTC
Created attachment 201237 [details]
Update to version 4.7

OK, let's close this Gestalt.  Update to the latest version 4.7, now all tests pass identically when built against GNU or BSD make (GNU make is not required though).
Comment 17 Alexey Dokuchaev freebsd_committer 2019-01-18 14:22:52 UTC
Reopen and request another exp-run.
Comment 19 commit-hook freebsd_committer 2019-01-21 13:35:36 UTC
A commit references this bug:

Author: danfe
Date: Mon Jan 21 13:35:03 UTC 2019
New revision: 490862
URL: https://svnweb.freebsd.org/changeset/ports/490862

Log:
  Unbreak the build against upcoming GNU sed version 4.7 and actually fix
  the pgBadger.pod generation.  Unlike GNU make, BSD make does not define
  $< variable for explicit rules, but earlier versions of GNU sed did not
  complain about missing filename in r/R/w/W commands.

  PR:	215768 (exp-run for gsed 4.7)

Changes:
  head/databases/pgbadger/Makefile
Comment 20 Alexey Dokuchaev freebsd_committer 2019-01-21 13:44:11 UTC
Thanks Antoine.  Once you believe we're good now, could you reassign PR to me so I can commit the update?
Comment 21 Antoine Brodin freebsd_committer 2019-01-21 14:06:57 UTC
The only new failure was pgbadger
Comment 22 commit-hook freebsd_committer 2019-01-21 14:38:24 UTC
A commit references this bug:

Author: danfe
Date: Mon Jan 21 14:37:47 UTC 2019
New revision: 490864
URL: https://svnweb.freebsd.org/changeset/ports/490864

Log:
  Update GNU sed to version 4.7.

  PR:		215768
  Submitted by:	pfg
  Exp-run by:	antoine

Changes:
  head/textproc/gsed/Makefile
  head/textproc/gsed/distinfo
  head/textproc/gsed/pkg-plist
Comment 23 Alexey Dokuchaev freebsd_committer 2019-01-21 14:58:10 UTC
The port was updated as of ports r490864, thanks everyone involved and sorry it took so long!
Comment 24 Xin LI freebsd_committer 2019-01-21 18:21:58 UTC
(In reply to Alexey Dokuchaev from comment #23)
Thank you for making this happen!