Bug 215854 - x11/i3lock dependency issue
Summary: x11/i3lock dependency issue
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Baptiste Daroussin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-07 16:29 UTC by Fabian Keil
Modified: 2017-04-08 08:51 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (bapt)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Keil 2017-01-07 16:29:30 UTC
After changing the quarterly branch from 2016Q4 to 2017Q1,
doing a bulk update with poudriere and running "pkg ugprade"
on my laptop, i3lock stopped working.

fk@t520 ~ $i3lock
/usr/local/lib/libxkbcommon-x11.so.0: version V_0.5.0 required by /usr/local/bin/i3lock not defined

Explicitly forcing an i3lock upgrade with "pkg upgrade -f i3lock"
solved the problem.

My impression is that x11/i3lock needs a PORTREVISION bump
or more precise LIB_DEPENDS.
Comment 1 Baptiste Daroussin freebsd_committer 2017-04-08 08:51:52 UTC
Sorry I missed it at the time :(