Bug 215866 - Update Port: lang/sbcl to 1.3.13
Summary: Update Port: lang/sbcl to 1.3.13
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Larry Rosenman
URL:
Keywords:
: 212307 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-01-07 23:26 UTC by Pavel Volkov
Modified: 2017-01-15 01:36 UTC (History)
5 users (show)

See Also:


Attachments
Update Port: lang/sbcl to 1.3.13 (20.53 KB, patch)
2017-01-07 23:26 UTC, Pavel Volkov
no flags Details | Diff
build log (779.82 KB, text/plain)
2017-01-07 23:29 UTC, Pavel Volkov
no flags Details
portlint log (19.24 KB, text/plain)
2017-01-07 23:30 UTC, Pavel Volkov
no flags Details
patch log (3.99 KB, text/plain)
2017-01-14 05:14 UTC, Pavel Volkov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Volkov 2017-01-07 23:26:16 UTC
Created attachment 178611 [details]
Update Port: lang/sbcl to 1.3.13

Update port lang/sbcl to current version 1.3.13.
Comment 1 Pavel Volkov 2017-01-07 23:29:46 UTC
Created attachment 178612 [details]
build log
Comment 2 Pavel Volkov 2017-01-07 23:30:15 UTC
Created attachment 178613 [details]
portlint log
Comment 3 Larry Rosenman freebsd_committer 2017-01-11 05:14:13 UTC
*** Bug 212307 has been marked as a duplicate of this bug. ***
Comment 4 Larry Rosenman freebsd_committer 2017-01-11 23:21:32 UTC
Can you check your changes to the Makefile against the current ports tree?  I get rejects against all the hunks in that file. 

Thanks!
Comment 5 charlz_klug 2017-01-13 15:52:12 UTC
(In reply to Larry Rosenman from comment #4)
I checked - SBCL builds successfully with option CCL (Clozure Common Lisp). Log: http://rgho.st/6KD4PTRpv
Comment 6 Pavel Volkov 2017-01-14 05:14:24 UTC
Created attachment 178874 [details]
patch log

Hello. I'm sorry. I was not able to repeat your mistake. Please look at this log and the command that I used.
Comment 7 Adam Weinberger freebsd_committer 2017-01-14 05:29:11 UTC
Larry it patches cleanly for me. Double check that you're using the right strip count and that your tree is clean?
Comment 8 Larry Rosenman freebsd_committer 2017-01-14 21:39:18 UTC
ok -- my screw up -- Test build in progress.
Sorry for the noise.
Comment 9 Larry Rosenman freebsd_committer 2017-01-14 22:56:53 UTC
Looks good, I needed to add makeinfo to the USES, but otherwise great job. 

Awaiting my mentors approval to commit.
Comment 10 commit-hook freebsd_committer 2017-01-15 01:34:58 UTC
A commit references this bug:

Author: ler
Date: Sun Jan 15 01:34:46 UTC 2017
New revision: 431505
URL: https://svnweb.freebsd.org/changeset/ports/431505

Log:
  Update lang/sbcl to 1.3.13
  Give MAINTAINERship to submitter, modernize port.

  PR:	215866
  Submitted 	by:Pavel Volkov (pavelivolkov gmail com)
  Approved by:	adamw (mentor)
  Differential Revision:	https://reviews.freebsd.org/D9186

Changes:
  head/lang/sbcl/Makefile
  head/lang/sbcl/distinfo
  head/lang/sbcl/files/
  head/lang/sbcl/files/patch-src_runtime_thread.c
  head/lang/sbcl/files/patch-src_runtime_x86-64-bsd-os.c
  head/lang/sbcl/files/patch-tools-for-build_grovel-headers.c
  head/lang/sbcl/pkg-plist
Comment 11 Larry Rosenman freebsd_committer 2017-01-15 01:36:35 UTC
Committed, thanks.  We made a bunch of tweaks, you see the details in 
the referenced Differential Revision. 

Thank you for picking up and modernizing and cleaning up this port.