Bug 215869 - www/apache24: continuously dumping core after an upgrade 2.4.23_1 -> 2.4.25_1
Summary: www/apache24: continuously dumping core after an upgrade 2.4.23_1 -> 2.4.25_1
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-apache (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-08 11:02 UTC by rustamabd
Modified: 2017-02-22 20:48 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (apache)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rustamabd 2017-01-08 11:02:09 UTC
After upgrading apache24 to 2.4.25_1, getting lots of:

kernel: pid 72245 (httpd), uid 80: exited on signal 11 (core dumped)

Nothing else has changed on the system.

FreeBSD 10.3-r15 amd64

Upgraded to php70, the issue remains.
Rolled back to apache24-2.4.23_1, the issue is gone.

Pse contact me for the core files.
Comment 1 rustamabd 2017-01-08 13:37:22 UTC
Looks like the issue is in mod_proxy_ajp.

Maybe this patch will resolve it:
http://svn.apache.org/viewvc?view=revision&revision=1775775
Comment 2 rustamabd 2017-01-13 09:28:52 UTC
Also seems to not happen in 11.0, only in 10.3.
Comment 3 Olli Hauer freebsd_committer 2017-02-22 20:39:56 UTC
Not sure if this is an mod_proxy_ajp issue.
In prod. I run only 10.3(amd64) frontend servers with mod_proxy_ajp and haven't seen any instability even on systems with 20 - 50 hits/s.
But I have to admit none of my frontend servers running PHP ...

If I interpret the change and the changelog correct it fixes only an issue if loglevel is set to trace2
Comment 4 rustamabd 2017-02-22 20:48:08 UTC
The patch did not resolve it indeed, but all is fine in 11.0. So putting this one to rest, hopefully will never occur again.