Bug 215870 - Install error - Harddrive disappears after formatting on ASUS X102BA notebook
Summary: Install error - Harddrive disappears after formatting on ASUS X102BA notebook
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-08 11:37 UTC by Robert
Modified: 2017-04-01 00:19 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert 2017-01-08 11:37:15 UTC
Trying to install FreeBSD 12 CURRENT (and TrueOS) on an ASUS X102BA notebook with SSD. The install looks at first successful, but after reboot there's nothing there. It just goes back to the install menu or if I remove the USB-pin I just get a black screen with text "insert proper boot media". A look in BIOS/UEFI confirms that the harddrive is disappeared. When I overwrite the disk with zeros it gets back in BIOS, so it seems there's nothing wrong with the harddrive.

I tried FreeBSD both with ZFS and UFS formatting, but there's no difference. It also doesn't matter if I try to install from UEFI or plain BIOS, it only changes the screen resolution, but otherwise there is no other difference.

The computers Secure Boot is disengaged and CSM is engaged.

As a test I tried to install Linux Mint and Ubuntu, and those installs with no problem.

As far as I can understand it has something to do with the formatting or partitioning. A computer workshop I've been talking to says that this is a fairly common problem and that it needs some kind of SATA-RAID driver. I don't know. There is a long thread on the TrueOS Community here https://discourse.trueos.org/t/tried-to-install-trueos-today-no-luck/216

(I don't know if I've chosen the right component above. If not, you may change it to the right one)
Comment 1 Robert 2017-01-09 10:37:51 UTC
Specs and more for the ASUS X102BA notebook https://www.asus.com/Notebooks/X102BA
Comment 2 Robert 2017-04-01 00:19:55 UTC
A tiny update on this on this bug report. I know this is for FreeBSD but in may still be interesting for the troubleshoting

I tried to install the TrueOS version of 2017-02-22 and installed from BIOS and with MBR instead of default UEFI and GPT.

The result is that the harddrive stays visable in BIOS, but it still won't boot up after installation. On screen I now get following:

F1 FreeBSD
F5 Drive 1
F6 PXE
Boot : F1 ################################## etc. (the # shows up one after another)

- Hitting F1 or Enter just gives another #
- Hitting F5 or F6 starts a new install process from BIOS.
- Unplugging the USB only removes the option "F5 Drive 1".
- Enabling or disabling "Launch PXE OpROM" in BIOS makes no change.
- Setting the USB as first boot option in BIOS starts a new install process with default UEFI.