Bug 216012 - /usr/lib/libgcc_s.so underlinks libc breaking linking with ld.gold
Summary: /usr/lib/libgcc_s.so underlinks libc breaking linking with ld.gold
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: Ed Maste
URL:
Keywords: regression
Depends on:
Blocks: 213480
  Show dependency treegraph
 
Reported: 2017-01-13 02:55 UTC by Jan Beich
Modified: 2020-05-04 22:59 UTC (History)
1 user (show)

See Also:


Attachments
LIBADD+= c in libgcc_s Makefile (1.70 KB, patch)
2017-01-13 03:18 UTC, Ed Maste
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-01-13 02:55:53 UTC
Below example is a snippet from configure check in www/firefox. Rebuilding world WITHOUT_LLVM_LIBUNWIND=1 makes the issue disappear.

$ pkg install -qy binutils fontconfig
$ mkdir gold
$ ln -s /usr/local/bin/ld.gold gold/ld
$ echo 'int main() {}' >a.c
$ cc -Bgold -L/usr/local/lib -lfontconfig a.c
/usr/lib/libgcc_s.so: error: undefined reference to 'free'
/usr/lib/libgcc_s.so: error: undefined reference to 'malloc'
/usr/lib/libgcc_s.so: error: undefined reference to '__stderrp'
/usr/lib/libgcc_s.so: error: undefined reference to 'memcpy'
/usr/lib/libgcc_s.so: error: undefined reference to 'getenv'
/usr/lib/libgcc_s.so: error: undefined reference to 'abort'
/usr/lib/libgcc_s.so: error: undefined reference to 'fflush'
/usr/lib/libgcc_s.so: error: undefined reference to 'memset'
/usr/lib/libgcc_s.so: error: undefined reference to '__assert'
/usr/lib/libgcc_s.so: error: undefined reference to 'snprintf'
/usr/lib/libgcc_s.so: error: undefined reference to 'fprintf'
/usr/lib/libgcc_s.so: error: undefined reference to 'fwrite'
cc: error: linker command failed with exit code 1 (use -v to see invocation)
Comment 1 Ed Maste freebsd_committer 2017-01-13 03:18:52 UTC
Created attachment 178846 [details]
LIBADD+= c in libgcc_s Makefile
Comment 2 Jan Beich freebsd_committer 2017-01-13 03:21:30 UTC
Comment on attachment 178846 [details]
LIBADD+= c in libgcc_s Makefile

>  LDFLAGS+=	-nodefaultlibs
> +LIBADD+=	c

Why not drop LDFLAGS line instead?
Comment 3 Ed Maste freebsd_committer 2017-01-13 03:29:13 UTC
(In reply to Jan Beich (mail not working) from comment #2)

This is what the GNU libgcc Makefile did, and I have a small preference to make it explicitly only libc.
Comment 4 commit-hook freebsd_committer 2017-01-13 15:17:56 UTC
A commit references this bug:

Author: emaste
Date: Fri Jan 13 15:17:25 UTC 2017
New revision: 312076
URL: https://svnweb.freebsd.org/changeset/base/312076

Log:
  libgcc_s: add libc DT_NEEDED to fix underlinking

  PR:		216012
  Reported by:	jbeich
  MFC after:	1 week
  Sponsored by:	The FreeBSD Foundation

Changes:
  head/lib/libgcc_s/Makefile
Comment 5 Ed Maste freebsd_committer 2017-08-17 15:57:12 UTC
Committed in r312076, thanks for reporting. lib/libgcc_s has not been merged to stable/11 but if that's done in the future it should include all subsequent fixes.
Comment 6 commit-hook freebsd_committer 2020-05-04 22:59:50 UTC
A commit references this bug:

Author: dim
Date: Mon May  4 22:59:41 UTC 2020
New revision: 360643
URL: https://svnweb.freebsd.org/changeset/base/360643

Log:
  Merge additions of LLVM libunwind libgcc_eh and libgcc_s. This is in
  preparation of further LLVM merges.

  MFC r307230 (by emaste):

  Introduce lib/libgcc_eh and lib/libgcc_s for LLVM's implementation

  They are not yet connected to the build, but I am adding them to allow
  for easier testing, ports exp-runs, etc.

  Reviewed by:	ed
  Sponsored by:	The FreeBSD Foundation
  Differential Revision:	https://reviews.freebsd.org/D8188

  MFC r307231 (by emaste):

  libgcc_s: add libm dependencies from div{d,s,x}c3

  compiler-rt's complex division support routines contain calls to
  compiler builtins such as `__builtin_scalbnl`.  Unfortunately Clang
  turns these back into a call to `scalbnl`.

  For now link libm's C version of the required support routines.

  Reviewed by:	ed
  Sponsored by:	The FreeBSD Foundation
  Differential Revision:	https://reviews.freebsd.org/D8190

  MFC r307864 (by emaste):

  Move the LLVM-based libgcc_s to /lib

  When enabled, it should install in the same location as the existing
  library.

  Reported by:	antoine

  MFC r308001 (by emaste):

  libgcc_eh/libgcc_s: apply hidden visibility only to static libs

  MFC r308100 (by emaste):

  compile libunwind c source with -fexceptions

  When an exception is thrown the unwinder must unwind its own C source
  (starting with _Unwind_RaiseException in UnwindLevel1.c), so it needs to
  be built with unwinding data.

  MFC r308294 (by emaste):

  libgcc_s: make unspecified shlib symbols local

  We want only symbols explicitly specified in the Version.map.

  Sponsored by:	The FreeBSD Foundation

  MFC r308308 (by emaste):

  Connect new LLVM-based libgcc_eh & libgcc_s to the build

  Compiler-rt and LLVM's libunwind provide a suitable replacement for
  libgcc.a, libgcc_eh.a, and libgcc_s.so.

  Remove the now-unused LLVM_LIBUNWIND block from gnu/lib/libgcc.

  PR:		213480 [exp-run]
  Reviewed by:	brooks, ed
  Sponsored by:	The FreeBSD Foundation
  Differential Revision:	https://reviews.freebsd.org/D8189

  MFC r308379 (by emaste):

  add __divdi3 and __udivdi3 to libgcc_s symbol version map

  After r308294 they were missing on i386 (and previously were exported
  only accidentally).

  Reported by:	antoine

  MFC r308445 (by emaste):

  add missing i386 symbols libgcc_s symbol version map

  After r308294 they were missing on i386 (and previously were exported
  only accidentally).

  Reported by:	antoine

  MFC r312076 (by emaste):

  libgcc_s: add libc DT_NEEDED to fix underlinking

  PR:		216012
  Reported by:	jbeich
  Sponsored by:	The FreeBSD Foundation

  MFC r316101 (by ngie):

  Apply r315689 to lib/libgcc_s as well to unbreak the gcc xtoolchain build

  lib/libgcc_s consumes lib/libcompiler_rt/Makefile*. The NO_WERROR.gcc in
  lib/libcompiler_rt/Makefile doesn't seem to have made a difference in being
  able to build this, so sprinkle NO_WERROR.gcc here as well.

  Reported by:	Jenkins (FreeBSD-head-amd64-gcc)
  Tested with:	amd64-gcc-6.3.0 (devel/amd64-xtoolchain-gcc)
  Sponsored by:	Dell EMC Isilon

  MFC r320673 (by emaste):

  Sort entries in libgcc_s Version.map

  MFC r337585 (by dim):

  In r308100, an explicit -fexceptions flag was added for the C sources
  from LLVM's libunwind, which end up in libgcc_eh.a and libgcc_s.so.
  This is because the unwinder needs the unwinder data for its own
  functions.

  However, for the C++ sources in libunwind, -fexceptions is already the
  default, and this can have the side effect of generating a reference to
  __gxx_personality_v0, the so-called personality function, which is
  normally provided by the C++ ABI library (libcxxrt or libsupc++).

  If the reference ends up in the eventual libgcc_s.so, linking any
  non-C++ programs against it will fail with "undefined reference to
  `__gxx_personality_v0'".

  Note that at high optimization levels, the reference is usually
  optimized away, which is why we have never noticed this problem before.

  With clang 7.0.0 though, higher optimization levels don't help anymore,
  since the addition of address-significance tables [1] in
  <https://reviews.llvm.org/rL337339>.  Effectively, this always causes a
  reference to __gxx_personality_v0.

  After discussion with the upstream author of that change, it turns out
  that we should compile libunwind sources with the -fno-exceptions
  -funwind-tables flags instead.  This ensures unwind tables are
  generated, but no references to any personality functions are emitted.

  [1] https://lists.llvm.org/pipermail/llvm-dev/2018-May/123514.html

  Reported by:	jbeich
  PR:		230399

Changes:
_U  stable/11/
  stable/11/Makefile.inc1
  stable/11/gnu/lib/Makefile
  stable/11/gnu/lib/libgcc/Makefile
  stable/11/lib/Makefile
  stable/11/lib/libgcc_eh/
  stable/11/lib/libgcc_eh/Makefile.inc
  stable/11/lib/libgcc_s/
  stable/11/lib/libgcc_s/Makefile
  stable/11/lib/libgcc_s/Version.map