Bug 216039 - www/chromium on FreeBSD 10.3 : pages do not not load
Summary: www/chromium on FreeBSD 10.3 : pages do not not load
Status: Closed DUPLICATE of bug 212812
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-chromium (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-13 18:54 UTC by bourne.identity@hotmail.com
Modified: 2018-08-14 23:54 UTC (History)
4 users (show)

See Also:
cpm: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bourne.identity@hotmail.com 2017-01-13 18:54:13 UTC
I like to keep chromium as a backup browser, primary being firefox. I just installed chromium 54.0.2840.100_1 on my FreeBSD 10.3 amd64 box via pkg and then ran sysctl kern.ipc.shm_allow_removed=1.

Chromium does not work. Opening up any webpage results in a blank page, with a prompt after half a minute that the page has become unresponsive. I can Wait forever, or Kill (in which case I get the dreaded "Ah Snap! Something went wrong" ending).
Comment 1 Carlos J. Puga Medina freebsd_committer 2017-01-13 19:21:58 UTC
Try to create a new profile

% mv .config/chromium .config/chromium.old

and check if it solves your problem.
Comment 2 Carlos J. Puga Medina freebsd_committer 2017-01-13 19:36:42 UTC
Note that in order to keep this setting across reboots, you should add in /etc/sysctl.conf:

kern.ipc.shm_allow_removed=1
Comment 3 bourne.identity@hotmail.com 2017-01-14 14:23:33 UTC
I deleted ~/.config/chromium and ran 'pkg delete chromium', followed by an build of the www/chromium port - which took nearly 20 hours. The situation started the same way again : BBC initially opens, then pages loaded from there result in an empty page with the tab marked as Loading (forever).

I suppose there is a bug related to either chromium or one of the add-ons (more likely because BBC initially opens; only upon refresh of add-ons cache does something start going wrong). I manually removed all add-ons and reinstalled them from Web Store. This has got me to the position where everything works okay except for LastPass (which seems to be hung trying to log in/create account). Am using chrome without lastpass till the situation remains this.
Comment 4 bkarp 2017-01-18 13:08:34 UTC
FWIW, I've seen similar behavior in chromium 54 and am still seeing it in chromium 55 running on amd64 on FreeBSD 11.0-RELEASE-p2. In my case, in typical usage, I have many tabs open, and with high probability (perhaps 40-50%) upon opening a new tab and entering a URL, the page load hangs part-way through (with the tab indicating "loading" forever), with the body of the tab unresponsive (i.e., right-click doesn't bring up a menu, scrolling doesn't function, etc.). It appears that when this hang occurs, it hangs *all* open tabs for that origin (including ones that were previously responsive).

Upon reading the comments thus far, I just now tried moving my old ~/.config/chromium elsewhere to start over with a fresh profile. When I ran chromium 55 (built from portsnap as of late last night), I still got repeated failures as above trying to browse xe.com with only one other tab open; about 5 consecutive tab hangs as I repeatedly tried to browse xe.com. The sixth attempt didn't hang. I have no browser extensions enabled other than pdfium (as configured upon installing chromium 55 from ports).

This state of affairs has persisted for some time now, and is making me consider abandoning Chrome on FreeBSD (though I prefer it to Firefox...or would, if I could reliably load pages with it).

Are others seeing similar behavior?
Comment 5 Hannes Hauswedell 2017-01-25 21:16:08 UTC
Same here on two different computers. On one of the computer NOTHING loads, not even the "new page" or any chrome:// -URL. On the other some things initially load, but then after a few minutes I cannot open new tabs any more.
Removing the profile does not help for me.
Comment 6 Jonathan Chen 2017-02-01 18:56:01 UTC
This issue is a duplicate of:

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

and it's been around for quite a while now.
Comment 7 Carlos J. Puga Medina freebsd_committer 2018-08-14 23:54:24 UTC

*** This bug has been marked as a duplicate of bug 212812 ***