Bug 216043 - net/gtk-vnc: fails to build with clang 4.0
Summary: net/gtk-vnc: fails to build with clang 4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dimitry Andric
URL:
Keywords: needs-patch
Depends on:
Blocks: 216008
  Show dependency treegraph
 
Reported: 2017-01-13 23:18 UTC by Jan Beich
Modified: 2017-01-17 20:06 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-01-13 23:18:33 UTC
gmake[3]: Entering directory 'src'
Makefile:1788: *** target file 'vncdisplay.c' has both : and :: entries.  Stop.

--- src/.deps/libgtk_vnc_2_0_la-vncdisplay.Plo	clang39
+++ src/.deps/libgtk_vnc_2_0_la-vncdisplay.Plo	clang40
@@ -616,6 +616,8 @@ libgtk_vnc_2_0_la-vncdisplay.lo: vncdisp
   /usr/include/xlocale/_strings.h /usr/include/xlocale/_string.h \
   /usr/include/stdlib.h /usr/include/sys/stat.h /usr/include/sys/time.h
 
+vncdisplay.c:
+
 ../config.h:
 
 /usr/include/locale.h:

build log: http://sprunge.us/jYiD
Comment 1 Jan Beich freebsd_committer 2017-01-13 23:28:25 UTC
Dimitry, can you bisect the following change that confuses libtool?

$ echo 'int main() {}' >a.c

$ cc -MD -MP -MF a.Tpo -c a.c
$ cat a.Tpo
a.o: a.c

a.c:

$ clang39 -MD -MP -MF a.Tpo -c a.c
$ cat a.Tpo
a.o: a.c
Comment 2 Dimitry Andric freebsd_committer 2017-01-14 17:23:37 UTC
This is caused by http://llvm.org/viewvc/llvm-project?view=revision&revision=287138, which should have had no function change, so this was unintended.  I'll submit a PR and/or contact the author.
Comment 3 commit-hook freebsd_committer 2017-01-15 01:34:56 UTC
A commit references this bug:

Author: dim
Date: Sun Jan 15 01:34:07 UTC 2017
New revision: 312206
URL: https://svnweb.freebsd.org/changeset/base/312206

Log:
  Pull in r292032 from upstream llvm trunk (by Yaron Keren):

    Fix PR31644 introduced by r287138 and add a regression test.
    Thanks Dimitry Andric for the report and fix!

  This should restore -MP output to what it was before.

  Reported by:	jbeich
  PR:		216043

Changes:
  projects/clang400-import/contrib/llvm/tools/clang/lib/Frontend/DependencyFile.cpp
Comment 4 Jan Beich freebsd_committer 2017-01-17 20:06:47 UTC
I confirm, the port builds fine now on /projects/clang400-import@312309.