Bug 216082 - graphics/aqsis: fails to build with lang/gcc6 or later
Summary: graphics/aqsis: fails to build with lang/gcc6 or later
Status: Closed DUPLICATE of bug 220787
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2017-01-14 16:56 UTC by Jan Beich
Modified: 2018-01-12 13:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-01-14 16:56:06 UTC
libs/core/texturing_old/shadowmap_old.cpp:179:13: error:
      invalid operands to binary expression ('std::ifstream' (aka 'basic_ifstream<char>') and 'long')
                if ( file != NULL )
                     ~~~~ ^  ~~~~

build log: http://sprunge.us/ECab
regressed by: https://github.com/llvm-mirror/libcxx/commit/3a1b90a866b6
Comment 1 Jan Beich freebsd_committer 2017-01-14 16:56:29 UTC
(In reply to Dimitry Andric from bug 216034 comment #6)
> Note that the upstream author has reverted the commit causing this here:
>
> http://llvm.org/viewvc/llvm-project?rev=291921&view=rev
>
> and has also merged it to the 4.0 branch. I will import the upstream
> branch into the projects/clang400-import branch soon.

lang/gcc6 and later versions are also affected.

libs/core/texturing_old/shadowmap_old.cpp: In member function 'void Aqsis::CqShadowMapOld::LoadZFile()':
libs/core/texturing_old/shadowmap_old.cpp:179:13: error: no match for 'operator!=' (operand types are 'std::ifstream {aka std::basic_ifstream<char>}' and 'long int')
   if ( file != NULL )
             ^
Comment 2 Jan Beich freebsd_committer 2018-01-12 13:50:18 UTC
Fixed by switching to C++11.

*** This bug has been marked as a duplicate of bug 220787 ***