Bug 216201 - audio/clementine-player: fails to build with libc++ 4.0
Summary: audio/clementine-player: fails to build with libc++ 4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sean Bruno
URL:
Keywords: needs-patch
Depends on:
Blocks: 216008
  Show dependency treegraph
 
Reported: 2017-01-17 23:21 UTC by Jan Beich
Modified: 2017-02-02 09:00 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (sbruno)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-01-17 23:21:27 UTC
In file included from 3rdparty/libprojectm/Renderer/RenderItemDistanceMetric.cpp:8:
3rdparty/libprojectm/Renderer/RenderItemDistanceMetric.hpp:54:9: error:
      call to constructor of 'TypeIdPair' is ambiguous
        return TypeIdPair(typeid(const R1*).name(), typeid(const R2*).name());
               ^          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
3rdparty/libprojectm/Renderer/Renderable.hpp:118:2: note:
      candidate constructor
        TypeIdPair(const std::type_info & info1, const std::type_info & info2): id1(info1.nam...
        ^
3rdparty/libprojectm/Renderer/Renderable.hpp:119:2: note:
      candidate constructor
        TypeIdPair(const std::string & id1, const std::string & id2): id1(id1), id2(id2) {}
        ^

build log: http://sprunge.us/YOfT
regressed by: https://github.com/llvm-mirror/libcxx/commit/aa6429dc4198
Comment 1 Eric Fiselier 2017-01-17 23:53:16 UTC
This is my fault. I've fixed it in the libc++ trunk, and will merge the patch into 4.0.
Comment 2 Sean Bruno freebsd_committer 2017-01-17 23:56:06 UTC
I'm tagging this as "not a bug" ... but I don't know that its correct to do so, when there really is a bug, its just not in clementine player.
Comment 3 Jan Beich freebsd_committer 2017-01-18 08:47:26 UTC
This (and bug 216161) can be marked FIXED once Dimitry merges libc++ fix into /projects/clang400-import.