Bug 216255 - audio/pulseaudio: Update to 10.0
Summary: audio/pulseaudio: Update to 10.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gnome mailing list
URL:
Keywords: patch
: 214999 (view as bug list)
Depends on: 210548
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-19 09:40 UTC by lightside
Modified: 2017-01-24 15:33 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
Proposed patch (since 428895 revision) (3.05 KB, patch)
2017-01-19 09:40 UTC, lightside
lightside: maintainer-approval? (gnome)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description lightside 2017-01-19 09:40:33 UTC
Created attachment 179063 [details]
Proposed patch (since 428895 revision)

Patch to update audio/pulseaudio port from 9.0 to 10.0 version.

Look following link for changes:
https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/10.0/

- Remove devel/json-c from LIB_DEPENDS
- Adapt files/patch-src_pulsecore_atomic.h [*]
- Adapt pkg-plist

[*] I guess, possible to remove files/patch-src_pulsecore_atomic.h or replace it with following sed patch instead, if needed:
-8<--
	@${REINPLACE_CMD} -e 's|#if __FreeBSD_version < 600000|#if 0|' \
		${WRKSRC}/src/pulsecore/atomic.h
-->8-
Comment 1 commit-hook freebsd_committer 2017-01-19 18:16:20 UTC
A commit references this bug:

Author: jbeich
Date: Thu Jan 19 18:15:53 UTC 2017
New revision: 431892
URL: https://svnweb.freebsd.org/changeset/ports/431892

Log:
  audio/pulseaudio: update to 10.0

  Changes:	https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/10.0/
  ABI:		https://abi-laboratory.pro/tracker/timeline/pulseaudio/
  PR:		216255
  Submitted by:	lightside <lightside@gmx.com>
  MFH:		2017Q1

Changes:
  head/audio/pulseaudio/Makefile
  head/audio/pulseaudio/distinfo
  head/audio/pulseaudio/files/patch-src_pulsecore_atomic.h
  head/audio/pulseaudio/pkg-plist
Comment 2 Jan Beich freebsd_committer 2017-01-19 18:20:34 UTC
*** Bug 214999 has been marked as a duplicate of this bug. ***
Comment 3 Jan Beich freebsd_committer 2017-01-19 18:26:30 UTC
Thanks. Landed.
Comment 4 Jan Beich freebsd_committer 2017-01-19 18:29:40 UTC
audio/pulseaudio-module-sndio was bumped in ports r431893 but I haven't tested runtime.
Comment 5 commit-hook freebsd_committer 2017-01-24 15:33:59 UTC
A commit references this bug:

Author: jbeich
Date: Tue Jan 24 15:33:02 UTC 2017
New revision: 432349
URL: https://svnweb.freebsd.org/changeset/ports/432349

Log:
  MFH: r431892 r431893

  audio/pulseaudio: update to 10.0

  Changes:	https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/10.0/
  ABI:		https://abi-laboratory.pro/tracker/timeline/pulseaudio/
  PR:		216255
  Submitted by:	lightside <lightside@gmx.com>
  Approved by:	ports-secteam (feld)

Changes:
_U  branches/2017Q1/
  branches/2017Q1/audio/pulseaudio/Makefile
  branches/2017Q1/audio/pulseaudio/distinfo
  branches/2017Q1/audio/pulseaudio/files/patch-src_pulsecore_atomic.h
  branches/2017Q1/audio/pulseaudio/pkg-plist
  branches/2017Q1/audio/pulseaudio-module-sndio/Makefile