Bug 216371 - audio/musicpd: fatal error
Summary: audio/musicpd: fatal error
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-22 14:50 UTC by hideo
Modified: 2017-01-28 14:32 UTC (History)
1 user (show)

See Also:
riggs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hideo 2017-01-22 14:50:45 UTC
Have tried to get this to run with soxr since it was introduced without success:

terminate called after throwing an instance of 'std::runtime_error'
Jan 22 07:43 : fatal_error: MPD died from signal 6


Running on:

10.3-STABLE FreeBSD 10.3-STABLE #0 r302196 amd64
Comment 1 Zane C. Bowers-Hadley 2017-01-24 07:22:48 UTC
This is unrelated to soxr. I get the same thing here. I don't even have libsoxr installed and I get the exact same thing here.
Comment 2 hideo 2017-01-24 10:39:52 UTC
(In reply to Zane C. Bowers-Hadley from comment #1)

Found the same thing yesterday trying to build it with a variety of options.
Comment 3 Thomas Zander freebsd_committer 2017-01-24 19:40:11 UTC
This happens with default options as well? On 10.3/amd64?
Comment 4 hideo 2017-01-24 21:37:53 UTC
Yes, after an rmconfig and accepting the defaults, same error on start.
Comment 5 Zane C. Bowers-Hadley 2017-01-25 04:45:02 UTC
I am seeing this on 10-STABLE/amd64.

FreeBSD vixen42.vulpes.vvelox.net 10.3-STABLE FreeBSD 10.3-STABLE #1 r312433: Thu Jan 19 16:02:53 CST 2017     kitsune@vixen42.vulpes.vvelox.net:/usr/obj/arc/src/FreeBSD/base/stable/10/sys/GENERIC  amd64

Also did a rmconfig-recursive and rebuild everything via portupgrade -R musicpd and it still failed.

Noticed 215826 today. Just rebuilt and installed libexec/rtld-el and am seeing if that affects it.
Comment 6 Zane C. Bowers-Hadley 2017-01-25 16:22:10 UTC
Rebuilding everything, world included, did not solve it.
Comment 7 Thomas Zander freebsd_committer 2017-01-25 21:26:42 UTC
I can reproduce the problem here. Will look into it as soon as I can. Until then, patches are very welcome :-)
Comment 8 commit-hook freebsd_committer 2017-01-28 14:29:41 UTC
A commit references this bug:

Author: riggs
Date: Sat Jan 28 14:28:50 UTC 2017
New revision: 432625
URL: https://svnweb.freebsd.org/changeset/ports/432625

Log:
  Update to upstream version 0.20.3; fixes see below

  Detailed log:
  - Update to upstream version 0.20.3
  - Resolve c++ stdlib overlinking on FreeBSD-10, fixes [1]
  - Promote HTTPD to default OPTION (proposal by jungleboogie0@gmail.com)
  - Update REINPLACEs on example config file to match upstream changes
  - Add additional hint on directory permissions and ownership for
    initial mpd service start in pkg-message.in
  - Pet portlint

  PR:		216371
  Reported by:	hideo@lastamericanempire.com

Changes:
  head/audio/musicpd/Makefile
  head/audio/musicpd/distinfo
  head/audio/musicpd/files/patch-src_db_Count.cxx
  head/audio/musicpd/files/patch-src_db_DatabasePlaylist.cxx
  head/audio/musicpd/files/patch-src_db_DatabasePrint.cxx
  head/audio/musicpd/files/patch-src_db_DatabaseQueue.cxx
  head/audio/musicpd/files/patch-src_db_Helpers.cxx
  head/audio/musicpd/files/pkg-message.in