Bug 216377 - graphics/libdrm: fails to build on aarch64 after r431708 (4512 ports skipped)
Summary: graphics/libdrm: fails to build on aarch64 after r431708 (4512 ports skipped)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords: needs-patch, regression
Depends on:
Blocks: 201763 214580
  Show dependency treegraph
 
Reported: 2017-01-22 17:24 UTC by Jan Beich
Modified: 2017-01-23 14:20 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
armv6 fix (1.97 KB, patch)
2017-01-23 13:42 UTC, mikael.urankar
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-01-22 17:24:50 UTC
=======================<phase: package        >============================
===>  Building package for libdrm-2.4.74,1
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/libdrm/work/stage/usr/local/include/libdrm/vc4_gpq_defines.h: No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/libdrm/work/stage/usr/local/lib/libdrm_vc4.so: No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/libdrm/work/stage/usr/local/lib/libdrm_vc4.so.1: No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/libdrm/work/stage/usr/local/lib/libdrm_vc4.so.1.0.0: No such file or directory
*** Error code 1

http://thunderx1.nyi.freebsd.org/data/110arm64-default/432006/logs/errors/libdrm-2.4.74,1.log
http://thunderx1.nyi.freebsd.org/data/110arm64-default/431503/logs/libdrm-2.4.74,1.log
Comment 1 Shawn Webb 2017-01-22 20:04:11 UTC
I'm impacted by this, too. It looks like comms/gnuradio depends on something that depends on graphics/libdrm.
Comment 2 Jan Beich freebsd_committer 2017-01-23 13:27:39 UTC
$ make check-plist
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: include/freedreno/freedreno_drmif.h
Error: Orphaned: include/freedreno/freedreno_ringbuffer.h
Error: Orphaned: include/libdrm/vc4_qpu_defines.h
Error: Orphaned: lib/libdrm_freedreno.so
Error: Orphaned: lib/libdrm_freedreno.so.1
Error: Orphaned: lib/libdrm_freedreno.so.1.0.0
Error: Orphaned: libdata/pkgconfig/libdrm_freedreno.pc
===> Checking for items in pkg-plist which are not in STAGEDIR
Error: Missing: include/libdrm/vc4_gpq_defines.h
Error: Missing: lib/libdrm_vc4.so
Error: Missing: lib/libdrm_vc4.so.1
Error: Missing: lib/libdrm_vc4.so.1.0.0
===> Error: Plist issues found.
*** Error code 1
Comment 3 mikael.urankar 2017-01-23 13:42:30 UTC
Created attachment 179254 [details]
armv6 fix

It's also broken on armv6: there is a typo arm6 -> armv6 and the plist is wrong.
I'm attaching a patch that survives make check-plist / stage-qa on armv6. I will test on aarch64 soon.
Comment 4 commit-hook freebsd_committer 2017-01-23 13:57:30 UTC
A commit references this bug:

Author: jbeich
Date: Mon Jan 23 13:57:07 UTC 2017
New revision: 432219
URL: https://svnweb.freebsd.org/changeset/ports/432219

Log:
  graphics/libdrm: unbreak on armv6 + aarch64

  PR:		216377
  Submitted by:	mikael.urankar@gmail.com
  Approved by:	portmgr blanket

Changes:
  head/graphics/libdrm/Makefile
  head/graphics/libdrm/pkg-plist