Bug 216460 - 82599ES 10-Gigabit SFI/SFP+ Network Connection link constantly flaps
Summary: 82599ES 10-Gigabit SFI/SFP+ Network Connection link constantly flaps
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.0-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-net mailing list
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2017-01-25 15:12 UTC by John Legato
Modified: 2018-10-23 17:33 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Legato 2017-01-25 15:12:38 UTC
We have a system running 11.0-RELEASE-p2 FreeBSD 11.0-RELEASE-p2 #0: Mon Oct 24 06:55:27 UTC 2016  with using an Intel 82599 based Dual port SFP+ nic:

ix2@pci0:131:0:0:	class=0x020000 card=0x061115d9 chip=0x10fb8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82599ES 10-Gigabit SFI/SFP+ Network Connection'
    class      = network
    subclass   = ethernet

We're using an SFP+ SR optic with OM3 multimode fiber. We've configured the ix2 interface with an IP and brought it up. No carrier is shown and no traffic passes. We're finding that the link constantly moves between the UP/down state.
ix2: link state changed to UP
ix2: link state changed to DOWN
ix2: link state changed to UP
ix2: link state changed to DOWN
ix2: link state changed to UP



We are running driver version 3.13-k but have also tried the intel supplied  3.14 driver with no luck:

ix2: <Intel(R) PRO/10GbE PCI-Express Network Driver, Version - 3.1.13-k> port 0xd020-0xd03f mem 0xfb880000-0xfb8fffff,0xfb904000-0xfb907fff irq 64 at device 0.0 numa-domain 1 on pci11
ix2: Using MSIX interrupts with 9 vectors
ix2: Ethernet address: 0c:c4:7a:88:7d:58
ix2: PCI Express Bus: Speed 5.0GT/s Width x8
ix2: netmap queues/slots: TX 8/2048, RX 8/2048

We've tried a number of cables to eliminate a cable issue. The card works without issue under Linux on the exact same hardware. We've also tried FreeBSD 10.3 with the exact same results. Are hitting a known bug? If so is their a workaround?
Comment 1 Kevin Bowling freebsd_committer 2017-03-05 05:03:49 UTC
I ran into a similar issue in 2014 and wasn't able to solve it, I ended up switching to Chelsio NICs.

If you can build a kernel it would be interesting to have you test this though:
https://github.com/mattmacy/networking/tree/HEAD_MERGE/iflib-ixgbe-current
Comment 2 John Legato 2017-03-06 11:30:12 UTC
Thanks for the reply. In the interest of time, I swapped the card out for a Mellanox NIC so I'm unable to test the Intel card.
Comment 3 tanu_life 2018-03-28 13:25:37 UTC
Hi there 

I would suggest contacting the reseller you bought this item from or if you are within UK, you can also call a company called megnet , their website is https://www.megnet.co.uk they have helped me many times with situation like this.

You can also email them if you are outside to uk or chat with them on their website.

But the first point of contact should be the reseller who sold you this item.

I hope this helps