Bug 216501 - converters/iconv build: don't know how to make euc-jp.so
Summary: converters/iconv build: don't know how to make euc-jp.so
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexander Nedotsukov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-26 19:06 UTC by Cy Schubert
Modified: 2019-02-11 12:31 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cy Schubert freebsd_committer 2017-01-26 19:06:38 UTC
7bit charset.
0 subtables.
--- all_subdir_ces ---
===> ces (all)
make[2]: make[2]: don't know how to make euc-jp.so. Stop

make[2]: stopped in /wrkdirs/usr/ports/converters/iconv/work/iconv-2.0/ces
*** [all_subdir_ces] Error code 2

make[1]: stopped in /wrkdirs/usr/ports/converters/iconv/work/iconv-2.0
1 error

make[1]: stopped in /wrkdirs/usr/ports/converters/iconv/work/iconv-2.0
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Platform is a recent current using poudriere. The same error occurs when building outside of poudriere.
Comment 1 w.schwarzenfeld freebsd_triage 2018-01-14 04:58:39 UTC
Maintainer feedback?
Comment 2 Cy Schubert freebsd_committer 2018-01-14 05:24:34 UTC
(In reply to w.schwarzenfeld from comment #1)
Why?
Comment 3 w.schwarzenfeld freebsd_triage 2018-01-14 05:32:24 UTC
Oh sorry, my fault.
Comment 4 Lorenzo Salvadore 2018-11-12 10:11:41 UTC
I tested converters/iconv (portversion 2.0_4) with poudriere on 11.2-RELEASE, both with amd64 and i386 and both with the only option set and unset: the build was always successful.

I guess the bug has been corrected and the bug report can be closed.
Comment 5 w.schwarzenfeld freebsd_triage 2019-02-11 11:49:00 UTC
see Comment4. Close here with overcome by events.
Comment 6 Cy Schubert freebsd_committer 2019-02-11 12:08:24 UTC
(In reply to w.schwarzenfeld from comment #5)
w.schwarzenfeld@utanet.at. Never do that again. Quit trolling!
Comment 7 Cy Schubert freebsd_committer 2019-02-11 12:31:43 UTC
Looks like it works again under poudriere under 13-CURRENT.

===> util (install)
install  -s -o root -g wheel -m 555   biconv /wrkdirs/usr/ports/converters/iconv
/work/stage/usr/local/bin/biconv
install  -o root -g wheel -m 444 biconv.1.gz  /wrkdirs/usr/ports/converters/icon
v/work/stage/usr/local/man/man1/
{  echo "# BEGIN iconv";  cat /wrkdirs/usr/ports/converters/iconv/work/iconv-2.0
/ccs/charset.aliases /wrkdirs/usr/ports/converters/iconv/work/iconv-2.0/ces/char
set.aliases  | /wrkdirs/usr/ports/converters/iconv/work/iconv-2.0/iconv_builtin
-n us-ascii utf-8 ucs-4-internal;  echo "# END iconv";  } > /wrkdirs/usr/ports/c
onverters/iconv/work/stage/usr/local/share/iconv/charset.aliases
====> Compressing man pages (compress-man)
===========================================================================
=======================<phase: package        >============================
===>  Building package for iconv-2.0_4
===========================================================================
=>> Cleaning up wrkdir
===>  Cleaning for iconv-2.0_4
build of converters/iconv | iconv-2.0_4 ended at Wed Feb  6 12:17:21 PST 2019
build time: 00:00:52