Bug 216638 - sysutils/burp: fails to build with clang 4.0
Summary: sysutils/burp: fails to build with clang 4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mark Linimon
URL:
Keywords: patch
Depends on:
Blocks: 216008
  Show dependency treegraph
 
Reported: 2017-01-30 23:56 UTC by Jan Beich
Modified: 2018-03-29 04:11 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (loic-freebsd)


Attachments
svn-diff-burp (3.23 KB, patch)
2017-12-22 04:13 UTC, Walter Schwarzenfeld
no flags Details | Diff
svn-diff-burp (3.22 KB, patch)
2017-12-22 23:23 UTC, Walter Schwarzenfeld
no flags Details | Diff
svn-diff-burp_v2 (3.54 KB, patch)
2017-12-23 18:37 UTC, Walter Schwarzenfeld
no flags Details | Diff
svn-diff-burp_v3 (4.03 KB, patch)
2017-12-23 20:19 UTC, Walter Schwarzenfeld
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-01-30 23:56:13 UTC
server.c:546:25: error: ordered comparison between pointer and zero ('struct strlist **' and 'int')
                if(!ret && cconf->keep>0)
                           ~~~~~~~~~~~^~

build log: http://package18.nyi.freebsd.org/data/headamd64PR216008-default/2017-01-29_16h09m05s/logs/errors/burp-1.4.40_1.log
regressed by: https://github.com/llvm-mirror/clang/commit/4b6ad14285f3
Comment 1 Walter Schwarzenfeld freebsd_triage 2017-12-22 04:13:55 UTC
Created attachment 189027 [details]
svn-diff-burp
Comment 2 Walter Schwarzenfeld freebsd_triage 2017-12-22 23:23:28 UTC
Created attachment 189044 [details]
svn-diff-burp

Changed one line in patch-xattr.c (comparison was not right).
Comment 3 Walter Schwarzenfeld freebsd_triage 2017-12-23 18:37:53 UTC
Created attachment 189061 [details]
svn-diff-burp_v2

Sorry, sent the wrong Makefile version (with compiler:c++11-lib.
Comment 4 Walter Schwarzenfeld freebsd_triage 2017-12-23 20:19:11 UTC
Created attachment 189067 [details]
svn-diff-burp_v3
Comment 5 Walter Schwarzenfeld freebsd_triage 2017-12-23 20:19:44 UTC
Was still a typo in. This should now work.
Comment 6 Daniel Winter 2018-01-22 15:59:12 UTC
Thank you for the patch!

I can confirm compilation works well after casting correctly, however this is still not integrated in the current ports tree. Is this port still maintained?
Comment 7 Walter Schwarzenfeld freebsd_triage 2018-01-22 16:06:39 UTC
No, it is back to the pool.
Comment 8 commit-hook freebsd_committer 2018-03-28 17:17:24 UTC
A commit references this bug:

Author: linimon
Date: Wed Mar 28 17:16:48 UTC 2018
New revision: 465828
URL: https://svnweb.freebsd.org/changeset/ports/465828

Log:
  Fix build on 11 due to clang4 regression.

  PR:		216638
  Submitted by:	jbeich

Changes:
  head/sysutils/burp/Makefile
  head/sysutils/burp/pkg-plist
Comment 9 Mark Linimon freebsd_committer freebsd_triage 2018-03-29 04:02:33 UTC
Committed, thanks.