Bug 216670 - [MAINTAINER] net-mgmt/collectd5: update to 5.7.1
Summary: [MAINTAINER] net-mgmt/collectd5: update to 5.7.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Joseph Mingrone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-31 08:00 UTC by Krzysztof
Modified: 2017-02-09 00:47 UTC (History)
1 user (show)

See Also:


Attachments
collectd ver 5.7.1 (1.17 KB, patch)
2017-01-31 08:00 UTC, Krzysztof
ports: maintainer-approval+
Details | Diff
collectd ver 5.7.1 corrected (1.11 KB, patch)
2017-02-03 13:18 UTC, Krzysztof
ports: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Krzysztof 2017-01-31 08:00:18 UTC
Created attachment 179468 [details]
collectd ver 5.7.1

There is new version of collectd. I'm attaching a patch which updates port. This port was checked with poudriere - you can see log at http://uld.bsdserwis.com/pkg/data/10x64-testing/2017-01-30_22h19m34s/logs/collectd-5.7.1.log
Comment 1 Joseph Mingrone freebsd_committer 2017-02-03 13:06:32 UTC
Did you intentionally remove PKGNAMESUFFIX?
Comment 2 Krzysztof 2017-02-03 13:18:54 UTC
Created attachment 179565 [details]
collectd ver 5.7.1 corrected

Yes, you are right. I removed PKGNAMESUFFIX by mistake. I've made a new patch
Comment 3 Joseph Mingrone freebsd_committer 2017-02-03 13:24:20 UTC
Thanks.  The patch to version-gen.sh no longer applies cleanly.  It's a simple fix, so I can do it, but I'm not clear why it is required.  Unless there is a .git directory the script always returns 5.7.1.git.
Comment 4 Krzysztof 2017-02-03 13:27:46 UTC
Well, I don't know :-))) As I became port maintainer it was done this way. So I don't change it - just patching to return current version.
Comment 5 Joseph Mingrone freebsd_committer 2017-02-04 18:18:54 UTC
Could you apply the patch at https://reviews.freebsd.org/D9444 to last version of the port in the tree?  I've test thoroughly in poudriere, but it needs a runtime test.
Comment 6 commit-hook freebsd_committer 2017-02-09 00:45:33 UTC
A commit references this bug:

Author: jrm
Date: Thu Feb  9 00:44:43 UTC 2017
New revision: 433704
URL: https://svnweb.freebsd.org/changeset/ports/433704

Log:
  net-mgmt/collectd5: Update to version 5.7.1.

  Other Changes:
    - Remove unnecessary global BUILD_DEPENDS, LIB_DEPENDS and RUN_DEPENDS.
    - Redo patches to fix portlint warnings.
    - Fix linked library errors reported by poudriere.

  Remaining issue:
    - When the XMMS option is selected, xmms.so is linked to libraries in
      devel/glib12 and x11-toolkits/gtk12, but adding
      XMMS_USE=GNOME=glib12,gtk12 causes a build error.

  PR:	216670
  Submitted by:	ports@bsdserwis.com (maintainer)
  Approved by:	swills (mentor)
  Differential Revision:	https://reviews.freebsd.org/D9444

Changes:
  head/net-mgmt/collectd5/Makefile
  head/net-mgmt/collectd5/distinfo
  head/net-mgmt/collectd5/files/patch-src__daemon__collectd.h
  head/net-mgmt/collectd5/files/patch-src__dns.c
  head/net-mgmt/collectd5/files/patch-src__modbus.c
  head/net-mgmt/collectd5/files/patch-src_zfs__arc.c
  head/net-mgmt/collectd5/files/patch-version-gen.sh