Bug 216708 - graphics/aseprite: Update to 1.1.13
Summary: graphics/aseprite: Update to 1.1.13
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords:
: 216706 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-02-02 01:13 UTC by Yuri Victorovich
Modified: 2017-02-08 21:04 UTC (History)
3 users (show)

See Also:


Attachments
patch (8.11 KB, patch)
2017-02-02 01:13 UTC, Yuri Victorovich
yuri: maintainer-approval+
Details | Diff
Revised patch (9.64 KB, patch)
2017-02-08 11:36 UTC, Guido Falsi
no flags Details | Diff
New patch (9.64 KB, patch)
2017-02-08 20:49 UTC, Guido Falsi
yuri: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2017-02-02 01:13:35 UTC
Created attachment 179505 [details]
patch

Passes poudriere on 11 amd64.
Comment 1 Guido Falsi freebsd_committer 2017-02-07 17:39:41 UTC
*** Bug 216706 has been marked as a duplicate of this bug. ***
Comment 2 Guido Falsi freebsd_committer 2017-02-08 11:36:03 UTC
Created attachment 179748 [details]
Revised patch

I made three changes,

- The pkg-message file does not need preprocessing, so you can put it directly in pkg-message in the port base directory. pkg-message.in in files is needed only when the file needs preprocessing, for example to replace %%LOCALBASE%% with the actual path.

- I reworded the pkg-message a little, I added a phrase shortly describing the problem being addressed since the user reading it could not be aware of the details.

- While testing I noticed this release identifies itself as 1.1.12-dev, looks like an upstream error, so I added a patch to fix the version number. This also avoids the software reporting an update to 1.1.13 is available.

Can you review the changes and approve the new patch?

Thanks.
Comment 3 Yuri Victorovich freebsd_committer 2017-02-08 17:27:24 UTC
You have a typo in pkg-message.in: Plesa.
Comment 4 Guido Falsi freebsd_committer 2017-02-08 20:49:50 UTC
Created attachment 179773 [details]
New patch

Sorry, Here is a new patch without the typo.
Comment 5 commit-hook freebsd_committer 2017-02-08 21:03:22 UTC
A commit references this bug:

Author: madpilot
Date: Wed Feb  8 21:02:48 UTC 2017
New revision: 433674
URL: https://svnweb.freebsd.org/changeset/ports/433674

Log:
  - Update graphics/aseprite to 1.1.13
  - Add pkg-message to inform users how to workaround mouse pointer
    lag

  PR:		216708
  Submitted by:	Yuri Victorovich <yuri@rawbw.com> (maintainer)

Changes:
  head/graphics/aseprite/Makefile
  head/graphics/aseprite/distinfo
  head/graphics/aseprite/files/patch-src_app_app__menus.cpp
  head/graphics/aseprite/files/patch-src_base_file__handle.cpp
  head/graphics/aseprite/files/patch-src_base_fs__unix.h
  head/graphics/aseprite/files/patch-src_config.h
  head/graphics/aseprite/pkg-message
  head/graphics/aseprite/pkg-plist
Comment 6 Guido Falsi freebsd_committer 2017-02-08 21:04:18 UTC
Committed. Thanks!