Bug 216735 - lang/qt5-qml: fails to build on armv6
Summary: lang/qt5-qml: fails to build on armv6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Many People
Assignee: kde
URL: http://beefy8.nyi.freebsd.org/data/he...
Keywords:
Depends on:
Blocks: 217208
  Show dependency treegraph
 
Reported: 2017-02-02 18:02 UTC by mikael.urankar
Modified: 2017-06-03 10:09 UTC (History)
2 users (show)

See Also:
tcberner: maintainer-feedback+


Attachments
armv6 fix (3.14 KB, patch)
2017-02-02 18:02 UTC, mikael.urankar
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mikael.urankar 2017-02-02 18:02:01 UTC
Created attachment 179540 [details]
armv6 fix

error:
../3rdparty/masm/wtf/Platform.h:299:6: error: "Not supported ARM architecture"
#    error "Not supported ARM architecture"

It blocks 163 ports on armv6.

The attached patch fixes the issue.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2017-02-09 18:49:11 UTC
I can confirm that this works for me as of 20170204.
Comment 2 mikael.urankar 2017-04-27 07:25:30 UTC
Hi,

It still blocks a lot of ports on armv6 (154).
Comment 3 mikael.urankar 2017-05-31 10:28:17 UTC
ping
Comment 4 commit-hook freebsd_committer 2017-06-03 10:06:45 UTC
A commit references this bug:

Author: tcberner
Date: Sat Jun  3 10:06:10 UTC 2017
New revision: 442470
URL: https://svnweb.freebsd.org/changeset/ports/442470

Log:
  Fix build on armv6

  PR:		216735
  Submitted by:	Mika?l Urankar <mikael.urankar at gmail.com>

Changes:
  head/lang/qt5-qml/Makefile
  head/lang/qt5-qml/files/patch-src_3rdparty_masm_assembler_ARMAssembler.h
  head/lang/qt5-qml/files/patch-src_3rdparty_masm_assembler_ARMv7Assembler.h
  head/lang/qt5-qml/files/patch-src_3rdparty_masm_wtf_Platform.h
Comment 5 Tobias C. Berner freebsd_committer 2017-06-03 10:07:14 UTC
Thanks for the patch.