Bug 216746 - graphics/appleseed: fails to build with clang 4.0
Summary: graphics/appleseed: fails to build with clang 4.0
Status: Closed DUPLICATE of bug 216745
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: i386 Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords: needs-patch
Depends on:
Blocks: 216008
  Show dependency treegraph
 
Reported: 2017-02-03 02:08 UTC by Jan Beich
Modified: 2017-02-03 03:51 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2017-02-03 02:08:09 UTC
/usr/bin/c++   ... -o appleseed.cli  ...
../appleseed/libappleseed.so: undefined reference to `__atomic_fetch_add_8'
../appleseed/libappleseed.so: undefined reference to `__atomic_store_8'
../appleseed/libappleseed.so: undefined reference to `__atomic_load_8'
../appleseed/libappleseed.so: undefined reference to `__atomic_compare_exchange_8'
c++: error: linker command failed with exit code 1 (use -v to see invocation)

http://package18.nyi.freebsd.org/data/headi386PR216008-default/2017-02-02_16h22m03s/logs/errors/appleseed-1.5.2.b_4.log
Comment 1 Jan Beich freebsd_committer 2017-02-03 03:51:07 UTC

*** This bug has been marked as a duplicate of bug 216745 ***