Bug 216893 - lib/libproc/proc_test:symbol_lookup fails on i386
Summary: lib/libproc/proc_test:symbol_lookup fails on i386
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: i386 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-07 19:11 UTC by Enji Cooper
Modified: 2018-07-27 15:54 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Enji Cooper freebsd_committer 2017-02-07 19:11:39 UTC
lib/libproc/proc_test:symbol_lookup fails on i386, but not on amd64. The failure is recent (within the past 3-4 weeks, since I was largely AFK for a month). proc_addr2sym seems to be at the core of the failure.

$ kyua test -k lib/libproc/Kyuafile 
proc_test:map_alias_name2map  ->  passed  [0.087s]
proc_test:map_alias_name2sym  ->  passed  [0.092s]
proc_test:map_prefix_name2map  ->  passed  [0.129s]
proc_test:signal_forward  ->  passed  [0.063s]
proc_test:symbol_lookup  ->  failed: /usr/src/svn/lib/libproc/tests/proc_test.c:142: error != 0: failed to look up symbol at 0x2804cbd0  [0.297s]
proc_test:symbol_lookup_fail  ->  passed  [0.107s]

Results file id is usr_tests_lib_libproc.20170207-190648-064178
Results saved to /home/ngie/.kyua/store/results.usr_tests_lib_libproc.20170207-190648-064178.db

5/6 passed (1 failed)
$ uname -a
FreeBSD fbsd12-i386.local 12.0-CURRENT FreeBSD 12.0-CURRENT #8 r313266:313267: Sat Feb  4 20:14:50 PST 2017     ngie@fbsd12-i386.local:/usr/obj/usr/src/svn/sys/GENERIC-NODEBUG  i386

$ kyua test -k /usr/tests/lib/libproc/Kyuafile                                                                                                                                    
proc_test:map_alias_name2map  ->  passed  [0.004s]
proc_test:map_alias_name2sym  ->  passed  [0.007s]
proc_test:map_prefix_name2map  ->  passed  [0.003s]
proc_test:signal_forward  ->  passed  [0.004s]
proc_test:symbol_lookup  ->  passed  [0.016s]
proc_test:symbol_lookup_fail  ->  passed  [0.005s]

Results file id is usr_tests_lib_libproc.20170207-190906-646576
Results saved to /home/ngie/.kyua/store/results.usr_tests_lib_libproc.20170207-190906-646576.db

6/6 passed (0 failed)
$ uname -a
FreeBSD fbsd12 12.0-CURRENT FreeBSD 12.0-CURRENT #7 r313183M: Fri Feb  3 19:45:10 PST 2017     ngie@fbsd12:/usr/obj/usr/src/svn/sys/GENERIC-NODEBUG  amd64
Comment 1 Mark Johnston freebsd_committer 2017-02-07 20:02:37 UTC
Works for me:

# kyua test
proc_test:map_alias_name2map  ->  passed  [0.008s]
proc_test:map_alias_name2sym  ->  passed  [0.007s]
proc_test:map_prefix_name2map  ->  passed  [0.006s]
proc_test:signal_forward  ->  passed  [0.007s]
proc_test:symbol_lookup  ->  passed  [0.015s]
proc_test:symbol_lookup_fail  ->  passed  [0.006s]

Results file id is usr_tests_lib_libproc.20170207-120737-256401
Results saved to /root/.kyua/store/results.usr_tests_lib_libproc.20170207-120737-256401.db

6/6 passed (0 failed)
# uname -a
FreeBSD  12.0-CURRENT FreeBSD 12.0-CURRENT #5 r313354+bc7b767c863a(dev-base): Tue Feb  7 11:53:13 PST 2017     markj@wkstn-mjohnston:/usr/obj/i386.i386/mnt/ssd2/markj/freebsd-dev/sys/BHYVE  i386