Bug 217042 - editors/libreoffice: configure: error: libGL required
Summary: editors/libreoffice: configure: error: libGL required
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-12 17:10 UTC by O. Hartmann
Modified: 2017-07-28 06:38 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (office)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2017-02-12 17:10:47 UTC
editors/libreoffice fails to build (among port multimedia/ffmpeg) after  Xorg server has been updated to 1.18.4.

Build system is FreeBSD 12.0-CURRENT #131 r313648: Sat Feb 11 20:14:28 CET 2017 amd64, ports tree revision is at 433953.

Graphical/GPU backend is nvidia (x11/nvidia-driver).

editors/libreoffice fails with:

[...]
checking whether to enable the VLC avmedia backend... no
checking for glBegin in -lGL... no
configure: error: libGL required.
===>  Script "configure" failed unexpectedly.
Please report the problem to office@FreeBSD.org [maintainer] and attach the
"/usr/ports/editors/libreoffice/work/libreoffice-5.2.5.1/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/editors/libreoffice
*** Error code 1