Bug 217113 - devel/hs-ShellCheck: update to 0.4.5
Summary: devel/hs-ShellCheck: update to 0.4.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-15 10:55 UTC by luca.pizzamiglio
Modified: 2017-03-02 18:22 UTC (History)
1 user (show)

See Also:


Attachments
The updating patch (884 bytes, patch)
2017-02-15 10:55 UTC, luca.pizzamiglio
luca.pizzamiglio: maintainer-approval+
Details | Diff
poudriere build on FreeBSD 10.3 i386 (49.10 KB, text/x-log)
2017-02-15 10:56 UTC, luca.pizzamiglio
no flags Details
poudriere build on FreeBSD 11 amd64 (42.47 KB, text/x-log)
2017-02-15 10:56 UTC, luca.pizzamiglio
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description luca.pizzamiglio 2017-02-15 10:55:44 UTC
Created attachment 180013 [details]
The updating patch

devel/hs-ShellCheck: updating to version 0.4.5

Updating this shell linter to the last version
Some fixes, several warnings added, some performance improvements.
No merge-quarterly needed.

portlint: OK (WARNINGS caused by bsd.cabal.mk import, not directly solvable)
testport: OK (poudriere: 10.3,11.0 on amd64,i386)
Comment 1 luca.pizzamiglio 2017-02-15 10:56:13 UTC
Created attachment 180014 [details]
poudriere build on FreeBSD 10.3 i386
Comment 2 luca.pizzamiglio 2017-02-15 10:56:34 UTC
Created attachment 180015 [details]
poudriere build on FreeBSD 11 amd64
Comment 3 commit-hook freebsd_committer 2017-02-15 11:57:36 UTC
A commit references this bug:

Author: tcberner
Date: Wed Feb 15 11:56:53 UTC 2017
New revision: 434158
URL: https://svnweb.freebsd.org/changeset/ports/434158

Log:
  Update devel/hs-ShellCheck to 0.4.5

  PR:		217113
  Submitted by:	luca.pizzamiglio@gmail.com
  Approved by:	luca.pizzamiglio@gmail.com (maintainer), rakuco (mentor)

Changes:
  head/devel/hs-ShellCheck/Makefile
  head/devel/hs-ShellCheck/distinfo