Bug 217202 - x11-servers/xorg-server: Xorg-Server 1.18.4 only starts as root
Summary: x11-servers/xorg-server: Xorg-Server 1.18.4 only starts as root
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Walter Schwarzenfeld
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-18 15:13 UTC by lausts
Modified: 2019-02-10 23:49 UTC (History)
3 users (show)

See Also:


Attachments
Diff file comparing Xorg.0 logs (67.41 KB, text/plain)
2017-02-18 15:13 UTC, lausts
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lausts 2017-02-18 15:13:42 UTC
Created attachment 180108 [details]
Diff file comparing Xorg.0 logs

I updated the Xorg-server package to version 1.18.4 this week and was unable to issue the 'startx' command as a regular user.  I was able to 'startx' as root.

After asking the FreeBSD-misc newsgroup for ideas we came to the conclusion that the xserver was looking for additional 'llvm' programs after it successfully found 'llvm39-3.9.1_1 because other programs needed earlier versions and these were not automatically deleted when llvm39 was installed.  Why things worked when only the root user started X is a mystery.  I did not keep any Xorg.0.logs when this was happening, but I attached a .diff file that was made during my troubleshooting effort.  When I removed all of the latest llvm packages other than the most recent everyting worked as expected.  My only hope is that some of my other packages will still function after removing all of the latest llvm's.

Tom
Comment 1 Niclas Zeising freebsd_committer 2017-12-16 20:33:08 UTC
Hi!
I have no problem running startx as a regular user.  To be able to use graphics acceleration, the user running 'startx' needs to be in the video group.

Can you reproduce this with a recent version of the xorg ports?
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-02-24 23:10:40 UTC
Feedback timeout?
Comment 3 Walter Schwarzenfeld freebsd_triage 2019-02-10 23:49:54 UTC
Feedback timeout: More than one year without answer.