Bug 217236 - lang/clang35: Allow building on recent head
Summary: lang/clang35: Allow building on recent head
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Brooks Davis
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-19 19:33 UTC by Dimitry Andric
Modified: 2017-02-22 00:50 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (brooks)


Attachments
Fix clang35 build on __FreeBSD_version >= 1200017 (3.44 KB, patch)
2017-02-19 19:33 UTC, Dimitry Andric
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitry Andric freebsd_committer 2017-02-19 19:33:37 UTC
Created attachment 180150 [details]
Fix clang35 build on __FreeBSD_version >= 1200017

Not sure if this port is still maintained, but it seems to be required by some other ports (e.g. haskell).  For a bug reproduction I needed lang/clang35, but I noticed that it doesn't build anymore on __FreeBSD_version 1200017 or later. This is due to a minor issue in include/llvm/ADT/IntrusiveRefCntPtr.h.

Here is a patch that fixes the header, both in devel/llvm35 and lang/clang35.
Comment 1 commit-hook freebsd_committer 2017-02-22 00:50:22 UTC
A commit references this bug:

Author: brooks
Date: Wed Feb 22 00:49:42 UTC 2017
New revision: 434557
URL: https://svnweb.freebsd.org/changeset/ports/434557

Log:
  Fix build on recent HEAD.

  PR:		217236
  Submitted by:	dim

Changes:
  head/devel/llvm35/files/patch-svn-218295
  head/lang/clang35/Makefile
  head/lang/clang35/files/patch-svn-218295
Comment 2 Brooks Davis freebsd_committer 2017-02-22 00:50:46 UTC
Thanks for the fix.